exporting to .3ds

hello all,

i am new to the community and i had just recently downloaded blender. the problem that i am having is that when i try to export to the .3ds file format, i get an error message saying: python script error: check console. are there any additional patches or something that i am supposed to download?

What system are you running?

Mac, Linux, or Windows?

I think most of the python scripts that aren’t intergrated into the blender build require a full python install
you can get it from http://python.org/download/

but you can see exactly what blender is complaining about in the terminal window

if you run it in Windows - it will be the other window that blender opens up when it starts
on Linux you will need to start blender from a terminal
(Mac I am unsure but I guess it would be the same as one of those)

in the window when blender starts it should say - looking for python version 2.5 (or similar) - then “got it” (if you have a full python install)

if it says something like continuing happily - you need to get python for your scripts to work

try that

and Welcome

i have windows vista

I’ve never run blender on Vista
does it open 2 windows?
(one is a terminal the other is the program)

check what it says in
the terminal window

.3ds export only works with a full install of Python. Took me ages to figure that out :frowning:

I have had this same problem for ages. The console reads " File “<string>”, line 127, in <module>,
Import Error: no module named struct.

What do u mean a 'full install of Python. I have installed Python 2.5 version linked it and Blender says its ‘Got It’. Is there a FULL FULL Python version we still need to download or something?

Is there maybe a bug in 2.44? It worked fine on an XP machine without Python in version 2.43, now it gives the error. But when I tried importing that .3ds file into Max, It gave me an invalid file type error. So I use .OBJ…more complete export format anyway.

You have the FULL install if it says “Got it”

this is most likely a version error like you have an old version of the script
it will probably be fixed by the author of the script for the 2.45 (not sure who the author is, but open the script in a text editor - you can do that in blender too)

but in the mean time check out the latest RC build
the scripts are bundled in that (might fix your problem)

or just use like .obj format as mentioned above