Exporting to .fbx not displaying as suspected

Hi guys,

I’m a programmer that recently started learning blender (for use with Unity) so may have been doing something very wrong from the start BUT… I got to the stage where I wanted to try importing my model and have so far tried a few things.

Initially I exported as .fbx but found this didn’t pass the textures over. Then I tried loading the .fbx file exported into the Autodesk .fbx converter and the subsequent fbx let me view the model and see the textures, but the actual model was not incorrect.

Then I finally read that unity can now directly read .blend files and convert them under the hood if the file is in the assets folder, but again it didn’t look the same. I feel like I’m probably missing something fairly straight forward.

I’ve attached the .blend file and tried attaching the .fbx generated by the converter but it wouldn’t let me.

Any help is much appreciated! and thank you all for supporting such a powerful piece of free software :slight_smile:


WallPiece.blend (453 KB)

I might be misunderstanding your problem, but here’s an overview of getting stuff from Blender to Unity.

Essentially, textures should not be part of the .fbx at all.

In Blender you create geometry with UV maps, and the texture image is a separate file. Once in Unity, you import the geometry from .fbx or .blend and it will show up as a blank model, and import the image file separately. To use them together, create a material inside Unity with the texture, and place the material on the MeshRenderer of whatever object uses your geometry.

Unity can automatically generate materials with the textures attached, and there are settings for this in the model import tab, but I generally turn that off because it clutters my asset organization.

Does this help?

Hmm, so is it not possible/advised to bundle the textures into the .fbx as well? I must have misunderstood. Is this the standard way of doing things then? I was just too excited about exporting a single file and importing it all ready to go as a prefab :slight_smile:

I found out why my models were screwed up (I’d heard the word normals thrown around but wasn’t actually sure what they were used for!) so managed to get that aspect sorted at least. Thanks for the help.

If you do manage to bundle textures into the .fbx in a way that Unity recognizes, it will be imported as multiple, separate assets anyway. For example, if I have a door object, doorframe object, and wood texture all bundled into one .fbx, you have three unrelated assets: door mesh, doorframe mesh, and wood texture. (Of course, if you drag that .fbx into a Unity scene from the Hierarchy window, it will create a prefab, kind of like autocomplete. But you have no obligation to keep those three assets together at all.)

My personal preference is to keep each asset in its own file simply because it’s easier to edit and organize.

I have kind-of similar problem. I have a model and it’s image textures. Model receive and recognize all it is texture right in the place. However, the FBX export jumble up all the textures like so:

The BLEND file has nothing wrong with it (so far as to my knowledge) and the files for the 3d viewer have all the textures along with the FBX in the ZIP file.
What could have gone wrong?