Exporting .X from blender - at my wits end!

Hi everyone, hopefully someone can save me from tearing my hair out.

I’m just trying to export a DirectX .x file. I’ve read everything, tried everything for 5 straight days, and I think there has to be something I’m missing, probably something simple.

Here’s the .blend file: http://www.rick-strom.com/temp/SpaceStationZero2.blend

I had it exporting without animation (which was better than nothing), but then I upgraded to 2.40a and now it won’t export at all (complaining that armature has no 'Get Bones" or something).

What I need is a mesh in two parts - a cylinder with a middle section that rotates. I created an armature, attached it to the middle part, and did the animation. Inside Blender, it runs perfectly. But when the export did load in the DirectX mesh viewer, it didn’t have the animation. I tried loading it in the toymaker.info meshviewer, which saw the animation and the bone, but didn’t run it for some reason.

Am I maybe going about this – procedurally – all wrong?

Thanks for any help anyone can give.

you should probably wait a bit before depending on 2.40 to export .x files properly. there really need to be some script updates. it will happen but y’know, gotta give people time.

i went and bugged the fine coders on the dev forum. maybe you can give your input and experiences there too… might make a compatible exporter happen faster.

http://www.blender.org/forum/viewtopic.php?t=7661

Right, but as I said, I just upgraded about an hour before posting, as a last attempt to get this model to export. I was unable to get it to export the animation under 2.37a despite 5 days of trying. I don’t think its a problem with Blender, I think it’s something I am doing wrong.

I had the best luck (in terms of the X file at least opening in mesh viewer) with the DirectXExportMod 1.3.2 script, but that one doesn’t work with 2.40. Regardless, again, it didn’t export animation under 2.37a either.