.exr file in blender Video Sequence Editor ?

I have a bunch of .exr images which when I add them into the Video Sequence Editor they do not show up, however when I open them in UV/image editor it shows just fine.
I need to be able to convert these .exr quickly into .png please help.

I just checked my files and they are the format OpenEXR Multilayer , not OpenEXR.
But yes I can open them in the uv/image editor and view them just fine, but I cannot view them in the Video Sequence Editor, also I can open them in the compositor as a single image but not as a image sequence.

I’m running both windows 7 and windows 8 which are also both are 64bit versions.
Blender 2.63a stable from the download page
Ill have tried the 2.64 test builds as well which both have the same issue.

No problem here on 64 bit linux. Both 2.63.0 and 2.63.17

Well that is great it runs for you , but I’m trying to find why its not working for me, try to be more help full and not waste my time thank you ;).

I’m running both windows 7 and windows 8 which are also both are 64bit versions.
Blender 2.63a
Ill try a different build.

edit, Tried a different build same issue.
I just checked my files and they are the format OpenEXR Multilayer , not OpenEXR.
But yes I can open them in the uv/image editor and view them just fine, but I cannot view them in the Video Sequence Editor, also I can open them in the compositor as a single image but not as a image sequence.

Hmm, I think that even a simple test on another system is helpful. At least it may narrow down a bug if you are able to classify it and enter it on the bug tracker.

Also i notice that you didn’t provide a specific build number, that could help with bug chasing too.

Good luck, I’m sorry that I could not offer more constructive advice. I hope that others will.

How about opening one frame in photoshop and saving as a flat OpenEXR? Then try just that frame in the VSE…

Just delete the alpha channel in Photoshop.

When you add a strip in the VSE it rarely appears at frame #1 (a very stupid feature indeed). Perhaps the strip is really there, but just off screen? Press the N-Key in the VSE window before you add the strip (this will open the properties panel). Then add the strip and manually set the start point in the properties panel to frame #1. If the strip is really there, but off screen it will have properties otherwise it may be a bug.

Are you using a tablet or a mouse?

You need to provide more information to avoid wasting my time. In future post relevant information such as your operating system and Blender build and get the facts right. Multilayer is not the same as single layer exr.

The VSE can’t decode Multilayer .exr. Multilayer files are intended for compositing so convert them to .exr or .png from the compositor first.

I don’t have a problem viewing the Multilayer sequence in the Compositor on 64 bit linux using 2.63.17. Didn’t test on 2.63.0 as I don’t intend wasting any more time on this. Problem is user error in my opinion.

I don’t think the build numbers will matter much , both installed blender versions which I use is the stable 2.63a and the test build of 2.64 found on blenders home page.

I have tried this but sadly being that it is a OpenEXR Multilayer not a normall OpenEXR so photoshop just shows a black screen, also I done some research to find that Photoshop does not really like OpenEXR on 64 bit system like I have. After which I have tried Gimp aswell but the plugin will not even work for me what so ever. sadly

Already tried this sadly no luck, I’m using a mouse at the moment as my trust tablet driver is not working to well with windows 8, and i don’t have it installed on windows 7.

Some things slip my mind such as which builds I’m using which i have gone back and edited my post ;).

I was trying to use the VSE to convert them to png.
I have also tried the compositor aswell to convert them but it won’t load it as a image sequence, yet it can load it as a single image.

I don’t wish to know what works for you, I need to get it to work for me, no offense but I don’t have much care for Linux.
Your last post was much better then the first thank you :wink:

Update, I have decided to re-render them frames as I loaded up Ubuntu 12.04 with Blender 2.63a from the main page and the same issues as I expected. Instead it may save me time to just re-render my work so say around 12 hours downtime for me but less headache.

EDIT images are now re-rendered so it’s no longer an issue

Well this doesn’t really help me as this doesn’t happen to work for me either, as I also have OpenEXR Multilayer. The compositor won’t open them as a sequence on 2.66a, which is a real pain, especially since I don’t have the luxury of time. Apparently I will be loading each image up into the compositor individually and saving out a few thousand images by hand eh? Fun.

My build is on Ubuntu 12.04, using the official 2.66.1 download from the site.

Since this is really a bug, I will be filing it shortly.

Also I don’t see why this can’t be loaded as a strip either, because it would be exceptionally useful. The integration between the compositor and the VSE really needs some love.

This is a job for the compositor. Here’s a quick summary (using 2.67b):
-open new and select composing screen layout and select use nodes in node editor.
-delete “Render Layers” node and insert image node (add>input>image). Attach image node to Composite node (Image to Image)
-click open image and select first .exr file. Change single image to image sequence and change frames to match the number of images you have.
-Change the render dimensions to match your image size. Change the render output to your desired format (PNG was mentioned above but you can also go to a video format) (note that the video editor can take EXR as long as it isn’t multilayer)
-make sure your output location doesn’t conflict with your input images and click animation (or Ctrl F12)

1 Like

During my first attempt to use EXR images for video rendering I stumbled upon the very same issue: I had rendered out my sequence as OpenEXR with multiple layers and then was wondering why the image strip did not show up in the VSE. So I opened the browser to find out how to deal with it. Then I saw your explanation above and gave it a try: I converted my pre rendered OpenEXR multilayered images to normal OpenEXR images, then created a new scene and finally added the newly created OpenEXR image strip without multiple layers to my VSE. But again the images do not show up! Wether in preview nor rendered!
I am using OS X Mavericks with the latest stable 2.69 release 64bit ( buildNr.: r60991) - Can anyone please explain how to use this image type correctly? The blender-wiki is not very informative about that…
Thanks in advance!
Best regards,


I had the same Problem. I add MultilayerEXR images in the Video Editor and the Stripe is there, but in the preview its black or transperent.
In the Compositor is the whole scene visible and also the in the UV editor.
To make the Stripe visible in the Video Editor preview I changed from Iamge stripe to Scene stripe and everything works fine.

Hopfully this helps…

Yes the VSE will read the output of another scene, in this respect it is quite handy but I’m not sure why you would bother with the double handling? Just render from the compositor? Unless you are inserting the frames into an animation… Still not sure it is a robust approach though.

Issue seems to be persistent in Blender 2.72b - I think it sets people off because you would not expect this format to be supported by all aspects of Blender, … but the VSE :-). Also, the fact that you cannot immediately distinguish between multilayer and single layer EXR (or can you?) will add confusion - it did for me until I found this post and also a dev log stating that the OpenEXR Multilayer format is for sure not supported in VSE. As OpenEXR Multilayer is fantastic for keeping your render passes in one place for compositing, people will probably use it consistently if HDD space is not an immediate issue. From a workflow perspective it would make sense to add a composition based on multilayer EXR into the VSE for putting out an animation (eg if you add motion blur etc.) but using the scene strip is a good approach. Especially if you add flares and other things through the VSE (rendered from the viewport).

The VSE has very limited compositing ability and is not well designed for this. I doubt that it would ever support multilayer EXR, unless as a meta strip with the contents broken out into strips. But this presents issues of layer mixing, as not all blend types are present in the VSE.

That is certainly accurate for me. I was glad to find this thread to confirm the VSE inability to work directly with OpenEXR MultiLayer images. It’s a pain to render to non-MultiLayer images just to output from the VSE when additional composting is not required.

Can someone describe the OpenEXR MultiLayer to VSE via Scene Strip work-around in a little more detail?

If no additional compositing is required there is surely no need to render passes to a multilayer file format?

You can use the multilayer .exr in the compositor and insert a scene strip in the VSE to render to video. It will send the output from the composite node to the sequence editor.

Ah yes, the Scene Strip works nicely. Thanks.

I’m using AWS cloud based Cycles nodes and file management is way more sane with a single set of files for all layers. Having the flexibility to do further compositing after seeing the render is a bonus and worth the disk space taken by OpenEXR MultiLayer.

For posterity, the process for VSE video rendering of OpenEXR MultiLayer files is:

  1. Start a new Blender file and set Render settings (Frame Range, Output type - e.g. MPEG/H.264, Output File)
  2. Switch to the Compositor, choose Use Nodes and delete the Render Layers node
  3. Add a Image node and Open all rendered OpenEXR MultiLayer files
  4. Connect the Image node to the Composite node
  5. Switch to the VSE and add a Scene Strip (strip length defaults to frame range set earlier)
  6. Switch back to Default and click Render Animation

Still working as today , tyvm