External Smoke Cache, cleared by starting Blender?!?

Hi,

i have an animation of 831 frames and i have three hi-res smoke domains in there.
In all three domains i did:

  • I have enabled “Smoke Cache > External” and i gave a directory name (but no file name).
  • I have set Start and End Frame to 1-831.

So I have hit ALT-A to have the cache filled up with the smoke simulation. That took 10 h or so.

Then I have quit blender and when i restart the next day, the cache seems empty.
Also, there is a message under File Path saying “No valid data to read!”

I use Blender 2.66 on Linux.

Before i also tried hitting “Bake” and “Bake All Dynamics”, but this seemed to not create any smoke at all.
That made me wonder, i expected this would fill the Cache.

Basically I want to calculate the smoke once and then after that get the render settings right for some frames.
After that i want to render an animation.

Can anybody give me a hint on how to do this?

Thanks for any hints
Torsten

The External flag is for reading the generated cache data, you don’t need it to be enabled for baking the data.

I created one scene to generate a cache. If you are using multiple domains in the same scene you will want to give each one a unique filename even though they will end up in the same cache folder. I called mine “my_smoke”.

Then, in a separate scene, I created two more smoke domains. Only this time I enabled External because I want those domains to read the data I previously generated. I browse to the cache folder and also filled out the filename field with “my_smoke”. This allowed me to deploy the same exact smoke data into two separate domains.

If you still have your cache data from your original bake you should be able to deploy it into a scene. Even if you do not name the caches, there is an index feature that should allow you to select which cache you want to deploy into a domain.

Attachments


Thank you for your hint, it clarified the “External” flag, i misunderstood this one before.

I’ve set up a new file for testing, so i don’t need to wait 10 h every time.

I use a particle system to emit the Smoke, so i first baked that particle system and then tried to bake the smoke.
That did not work, no smoke was generated.

When i use Mesh as Flow Source then i can bake the smoke.

It seems I have a problem when baking smoke that comes from a particle system. Also, when i don’t render the particle system, it seems no smoke is generated.

Thanks for any hints
Torsten

[SOLVED]: Those were temporary problems due to a full disk. With enough disk space baking is no problem.