extra verts after dissolve

I dissolved a few edge loops running through my mesh, but it leaves a bunch of stray vertices along my edges. I can fix it by merging the vertices one at a time, but there has to be a simpler way. Anyone have any ideas? Thanks.


:smiley: You made me laugh… Merging the vertices one by one is really the monomaniac way. Don’t you know that you can merge more than 2 vertices at a time? Any way, that’s not the best solution.

In the first place, you shouldn’t have dissolved the edge loops but deleted them… one by one. Alas, that’s all Blender can do for now.

But now that you’ve got this big mess, [B]ox-select, [C]ircle-select or [CTRL]-select the whole mess, [SHIFT Right-click] to deselect the vertices you want to keep and then dissolve the rest in one move.

Have you tried selecting all and ‘remove doubles’?
Not sure what the distance between them has to be before they are not considered ‘double’.

Remove doubles is what youre looking for, i think.


while dissolving edges press F6 and check “Dissolve Verts”

When you dissolve edges in edge select mode, there’s an option to also dissolve verts along with them. Press F6 after dissolve.

that dissolbe verts is wokring but not certain if it is doing what it shold do

try on a cune and subdivide one edge
then select only one ege in middle and dissolve
that will remove all edges and verts on the width of the cube

not certain this is waht it shold do may be a bug !

salutations

the dissolve verts option was exactly what I was looking for. Thanks

Like with all of your posts, I’m not 100% certain what you mean, so I’m going to guess you’re not sure what it should do with the corner vertices.

When you subdivide just one edge of the cube, you get two ngon faces. Flattened here:
[ATTACH=CONFIG]211522[/ATTACH]
Top row: edge to be dissolved
Bottom row: after dissolve

From left:

  • Normal edge dissolve would create one ngon face. Two vertices left. Dissolve verts option tooltip says “when dissolving faces/edges, also remove remaining vertices”
  • Which it does. On a cube, the edge loop doesn’t continue past that point so it removes them
  • Here it does so only the vertex in the middle gets removed with dissolve verts option on.

see pic hre

after selecting one edge and X for dissolve then you get only one big NGON


thanks