Extrude Issue

Hi, I´m selecting faces 90 degrees and apply extrude, but the extrusion is not ocurring at Normal direction of each face. I´m using Blender 2.75a, but the same occurs in 2.74, too.

Anybody could help me?


Do you want each face to extrude separately, if so Alt+E / extrude indivdual
or use E with pivot point set to individual origins and the transform orientation set to normal.
If you still want them joined, E / Esc / Alt+S (offset even setting in the shrink/flatten options will give different results)

The required options will depend on exactly the result you want to achieve and the starting mesh

Richard, the only way to get the result below is using Alt + S after Extrusion? I thought the default extrusion orientation was Normal…