extruded Bezier Curves and adding meterial???


(E=Mc²) #1

Ok, Im fairly new to blender so go easy on me im going though the tutorials in the blender 1.5 manual (riff raff) and in the “Flying Logo” tutorial it tells you to extrude the curves to give it a 3d look, which is no problem then it tells you to add 2 materials 1 gold color for the crown and 1 metalicgray color for the LOGO which is no problem how ever the display in the 3d window does not show the results??? the entire logo is just gray or gold??? im preaty sure that i have done this right because if i return the extruding back to zero in the edit panal the colors are right but flat what am i doing wrong when i extrude the logo? and how do i get a gold crown and a silver logo? if screen shots will help i will post some also i am using blender 2.23


(OTO) #2

Hello,
your post is quite confusing.
To show the objects materials in the 3d window Blender uses Open Gl.
Don’t expect to see reflections??
Is that you’re talking about.
But you can increase the Spec and Hard to get a metallic look
Bye
António


(VelikM) #3

Try ‘Alt-z’ Does it render correctly?


(E=Mc²) #4

Ok alt+z makes the image apear black. let me see if i can clear this up for you try this make two bezier circles side by side then push z and they apear gray press z again, now add two matterials and make one circle blue and one red, then press z now one circle is red and one is blue ok press z again now here is my problem if you go to the edit window and you extrude one of the circles changing EXT1:0.000 and EXT2:0.000 to any other value and you push z the circles only show gray is this right? and if i add lights and hit f12 the image is still gray i can not add color to my extruded bez circles just try this it will take you two secounds
here is a added note if i add just a cube mesh and add blue meterial to it and you hit z the cube will show up blue i can mold the cube into anything add it will still be blue when i hit z if i add lights and hit f12 the cube is blue why can i NOT add color to a extruded bezir curve???[/img]


(BgDM) #5

hmmm…

Well, I just did this and it worked fine for me. I have no idea. Maybe it is a problem with your video card?

BgDM


(VelikM) #6

I’ve tried to make it not work, but it works every time. ‘Alt-z’ works correctly, materials works correctly, extrude works…?


(E=Mc²) #7

hmmm i have tryed it on 2 pcs one with a geforce 2 mx 400 and the other is an hp with on board video the extrued works fine and i can add matireals but when i hit z to show what it would look like renderd it just shows up gray but if the curve isnt extruded and i hit z the colors show up fine…hmmm i did the two circle thing i ask you guys to do and that worked so i must have done somting with my logo that is preventing it from working do any of you have a email i will send you my blender file so you can see what i mean? i realy want to figure out what i did wrong its working with everything i have tried but it still wont work with my logo


(E=Mc²) #8

OMG! I dont know what the hell i was doing wrong but now all of a sudden it is working sorry to waste your guys time! and thanks so much for your help

OK so you know what i was doing wrong I never actualy assigning the gray material to the logo i just left that to default and was trying to just assign the gold material to the crown wich was single user

to fix it i just assigned 2 mat: 1 (gray) to the logo wich i didnt do befor and then assigned 2 mat: 2 (gold) to the crown this make sens? anyway i figured it out