Extruding from a plane

When I extrude a cube from a plane and then extrude a second attached cube from that, the shared edge between the two cubes will not be part of one of the faces. So if I select the face of one cube all four edges are part of the face. When I select the second face from the second cube, that same edge is not part of the face so that only 3 edges are selected with the face. It will only do this when extruding from a plane. Is there a way to “re-join” the 4th edge to face?

You’ve totally lost me with your attempt at a description.

It’s much easier if you show clear screenshots that show exactly what the problem is and attach or post a link to your blend file

Ctrl+J joins separate selected objects
Selecting all vertices and W / remove doubles merges vertices that are within the specified merge distance
Alt+M gives you merge options for selected faces.

What you’re describing does not sound right. Show a screen shot.


Attachments


Sorry for the double pic post, ignore the larger one. Edit screen screwed me.

I do not understand the problem… o.O

I figured it out. The problem was that I tried cancelling the extrude with ESC when I was creating the second cube. But, this only cancelled the grab function and not the extrude (I never pressed CTRL-Z to cancel the extrude). After only pressing ESC I pressed E again to extrude but it left extra geometry in between the two cubes. All I needed to do after cancelling the automatic grab was to undo the extrude. Problem solved!

Hurray! Good for you =)