Extruding scaled curves

Im scaling and extruding a curve and dont understand how the
extrude distance is calculated.
If I draw a curve, extrude by 1, it extrudes by one, in each direction.
If I draw a curve, extrude by 3, it extrudes by three in each direction.
no problem.

but when I

  1. draw a default curve.
  2. scale the curve by n, say 3. I used the key seq s3 and hit enter.
  3. use cntl-a to apply scale.
  4. Then extrude by 1. I used the property/data/geometry area that is normally on the right hand side.
  5. it gets extruded by a factor of 3 times or what ever n was.:frowning:

Where is this factor coming from. The cntl-a reset the scale factor to 1

I first tried this without applying the scale using the cntl-a incantation.
I figured the scale factor was being applied to the extrude field by magic.:wink:

When I applied the scale factor to the object, the scale factor was
reset to 1, as I expected. The internal vertex coordinate now shows a factor
of 3 increase, as I expected. but, the extrude of 1 gives me a extrude of 3.

Now I’m thinking black magic.:confused:

I see no place where this is coming from.
There seems to be some hidden history being kept or not cleaned up such that
the scaling history is effecting the extrude amount.

Im new to blender and happy to admit my ignorance but
is this an “operation anomaly” that should be report; and to whom.

or

can someone reduce my ignorance.

In using Blender 2.75+2.75-a~1436280969 under Ubuntu 14.4

Always scale in edit mode, then when you extrude with 3 it will extrude by 3

Thank you for your timely reply.

I have tried what you suggested, making sure I was in edit mode, no joy.
I get the same thing.

The sequence is
shift-a, curves/bezier; s3 enter; cntl-a, scale; tab; extrude 1; tab

I get a 6x6 wavy plane. I was expecting a 6x2 wavy plane.
I understand the part about extrude doing it in both directions.

I have tried it with all control points selected and not selected.
I have tried it both in edit mode and object mode, same outcome in all situations.

It still seems that after an object is scaled, that scaled factor is remember some place and used in the extrude

Just to be clear, the help text on the button is :
python: Curve.extrude
bpy.data.curves[“BezierCurve.001”].extrude

Thank you for your time and effort in helping me over come my ignorance on how this is suppose to work.
I’m still confused and can not predict the outcome of this operation since the scale factor being applied is not shown after it
has been applied.
In the general case if I scale a few time, trying get it right, I loose track of where I am and then extrude.

I tried scaling it up by 3, cntl-a and then 2, cntl-a and then reducing it by 3, cntl-a and then extruding by 1.
It extrudes 4, 2 in each direction. So something is keeping track. Its not just using the last scale because something didnt get cleaned up.