Extrusion Problem

I am working on the fender of a motorcycle. I want to add depth to the fender now that it has been modeled. The problem is, when I extrude, it doesn’t extrude in such a way that the top and bottom are in tact. It extrudes the faces but the original faces don’t remain. It’s hard to explain. See attached pics.

  1. Faces I want to extrude
  2. Extrusion done. Notice original faces are not left in place
  3. Flip fender over to see gap.

I was having the same problem when trying to get depth on the fender. I finally got it working, not sure how.

I included a pic of the project so far.

Attachments





I think I had that same problem with a subsurface,
where I couldn’t get it to extrude to create a shape, if that makes sense.
Like say I wanted to make a solid cup, I couldn’t get the inside of the cup
to extrude inwards, it would just add another layer of invisible uneditable subdivision,
and makes the subsurface shape tupperware bowl-like.
I just tried it again right now, and if the second extrude is scaled down a little,
it extrudes ok,if that’s the problem you might be having.
It tricks because the subsurf extrusion already seems to be scaled perfectly for modification/transformation. :smiley:
Also if I extrude and cancel the extrusions movement by right clicking right after,
sometimes the extruded vertexes merge with the old vertexes, regardless of subsurface or not, :smiley:
which doesn’t happen in the 2.46. rc versions.
That’s a cool motorcycle!

Well, the problem itself ist totally normal and everything else wouldn’t be logic.

You activated Subsurf in Edit-Mode, so your points already are on the interpolated positions. If you change the points around them, or add new ones, their position has to change too, otherwise it wouldn’t be subsurf…

Maybe you get the results you want if you crease (Shift+E->1) the Edges around the extrusion.

This simple process might do what you want.

http://blender.dothelp.net/tutorial-list/using-solidify-selection-script-to-make-nice-edges/

Actually, that script seems to extrude an edge. That works as expected. I had the same problem on the front fender, I’m not sure what I did, but I got it working correctly. It’s weird. Someone must have seen this.

http://download.blender.org/documentation/NaN_docs/Manual2.0/Extrude.html

This is the best description of the extrusion algorithm ever.
It is the third point that is giving you so much trouble.

Jean

Pie-Guy… I’ve added some more information at the begining of the tutorial which I think will help explain the advantages of this technique.

It’s not just an extrusion you get. It’s a full “L” shaped corner/edge that will not have render artifacts as the “back” side of the solidified edge is NOT ATTACHED to the surface of the mesh, which would be the result of what you have been trying to do.

Andy C… Your cup example is exactly what the “solidify selection” script is perfect for…
Sounds like you may also be using “automerge” without being aware of it’s effects.

Attachments


I don’t think so, I think it’s a widows 2000 thing, it happens every time
I cancel an extrusion movement on 2000…
All the vertex snap back as expected, but when I try and move them
3 out of 4 vertexes are merged and snaggled into the extrusion area.
I just tried and can’t recreate it on my xp.
I have to model with the Rinky beta version on my 2000 :smiley:

I just tried extruding several connected planes and it worked as expected.
I just don’t get it.

Attachments



Interesting, I added some more faces and the problem returned. Wacky.
I guess I just don’t understand how Blender determines which method to use.

Attachments