Eye lids shape keys passing through the eye

Hi,

I’m doing the Piero course of Blender Cookie and in the shape keys creation for the eye lids I have a problem:
the eye lids cross the eye object:




How can I fix it?

You may want to move the eye further back in the head and the scale it a bit larger. This will allow it to fill the open eye and not stick out so far forward out of the eye socket.

Or you could bring the closed position of the eye lid out more by scaling on the normals on the part of the eyelids that touch. Also scale on the normals the other edge loops to make it more round.

Good luck and Happy blending.

I got around this by moving the offending verts as part of my shape key, so that the full value was exactly what I wanted

How can I fix it?

use absolute shapekeys. Although I really can’t see why this should not be done with an armature and a bone …

How about using the Shrinkwrap modifier? Might even let you have the slight bulge caused by the iris region to be noticeable (might allow to see eye movements with the eyelids closed)

I got around this by moving the offending verts as part of my shape key, so that the full value was exactly what I wanted

Actually, that worked. I also had to increase the eyelid width, since it was too thin.

However, in the same workflow, I have another problem: mirror the shape key to the other eye.
In the tutorial, I have to:

  1. Delete old and unused shape keys.
  2. After doing corrections, create a new shape from mix for a natural eye lid movement, without the vertex groups.
  3. Create another one shape key using “New shape from mix”.
  4. Click in the down arrow, to show the shape key menu and select “Mirror shape key” option.

However, after applying the last operation I got this warning:

1620 vertices mirrored, 132 failed.

Along with this pretty ugly result:


I double checked and verified that everything is simetrical. Someone has a clue what might be generating this problem?

(link to the blend file: https://www.dropbox.com/s/pktrdud4najaqn5/piero_eyelid_prob.blend)

Likely because the mesh isin’t symmetrical. I removed shape keys, mirrored the whole mesh, removed right hand side from the left vertex group (that just got mirrored), redid the shape keys. Mirroring shape keys worked after that


Your model is so cute!