Eye Problems

Hi guys, 6 hours of ballsing around, can get no further.
After following Bijan Hematis’ brilliant eye tutorial I CANNOT get rid of this horrible ring around the Iris.
Anybody out there know how to resolve this?



EyeBall3.blend (272 KB)

The texture images aren’t packed with the blend so I can’t tell for sure exactly what effect you’re trying to achieve, however, your white ring is from the color ramp on your texture called Sclera.

Move the Pos 0 and Pos 1 ramp sliders on this texture closer together and the ring will shrink, or: Change the alpha value on the Pos 1 slider to 1 instead of 0 to get rid of it entirely. But this second option is the one I can’t tell if it’s what you’re looking for without the image files.

Thanks sck5000, I didn’t know blender doesn’t export it’s textures. It doesn’t matter because the problem exists without the textures. Briefly, I’m trying to have an opaque eye that gently transitions at the iris edge to full transparency. This doesn’t seem over complex to me but do you think I can achieve it? That wretched white line seems a fixture!!! Doesn’t matter what I do with Pos 1 or 2 ramp sliders. The white band shouldn’t be there at all, I haven’t the faintest idea where it’s coming from!

I’ve found a solution but not the source of the problem.
By clicking on ZTransp in the Render Panel I’m able to use Z Transparency instead of Raytrace in the Materials panel, presto, end of white band. I still haven’t figured out where that band came from while in Raytrace but am no longer so aggrieved.

If you’re using Blender 2.5 you can pack your texture files into the blend file by going to File -> External Data -> Pack into .blend file.

I can’t figure out why you have that white line but it still seems to me to be your color ramp on the Sclera texture, in conjunction with the Brightness/Contrast/Saturation settings and that you have the Alpha clicked on in influence… along with the fact that you’re using ray-traced transparency but you have no ray-tracing lamps. Ie: You have two hemi lamps, but these are not ray-traced lamps.

Try turning the subsurf off or add a couple of edgeloops near the white band.