Eyebrows problem

Hi there!

I’m currently working on the eyebrows of my model but ran into problems and I just can’t seem to figure out why!

So the way I’m doing it is simply add a hair particle system, turn the velocity way down. There’s no vertex group I’m assigning it to. And then I simply bring the emission down to 0. Next, I just go into Particle Mode and start adding hairs (Count: 1) onto the faces I want my eyebrows on.

Now the thing is, when I have my subsurf modifier turned off, the hair looks completely fine, coming out of the correct eyebrow faces I want it on. But when I start to turn it back on, it goes nuts. I see the added hair’s starting points at the nose and mouth area and I have no idea why it went all the way there.

Hope I could get some advice on this! Much appreciated! :slight_smile:

Try moving the Subsurf Modifier below the Particles System modifier on the stack.

Strand location is somehow tied to the mesh topology (I don’t know the details, though). Subsurf changes the topology of the mesh, so if you add hair strands while it’s off, they get scrambled when it’s turned back on because the underlying mesh is changed. The same thing will often happen if you add or subtract verts from the mesh after adding the hair system. This is why I often use separate mesh emitters for hair systems.


Thanks for the reply! Yeah I was playing around, moving the brow hair particle up the subsurf modifier and somehow it worked. It’s kind of weird though that even though my head’s hair particle (separate from the brow’s particle) is below the subsurf and it wasn’t affected that much at all. Anyways thanks again!

If you have the Subsurf modifier enabled while placing the hair strands, it has a different effect than if Subsurf is off & then turned on afterward. Whichever condition is in effect when you place or groom (edit) the hair strands will be the “optimum” setting for hair strands. So it’s quite possible to have Particle systems both above and below the Subsurf modifier and act properly.