F curves don't work with scaling. :( Any workaround?

I am creating an “infinite zoom” using Blender’s compositor: a series of images changes scale. For that I need to adjust the bezier curves, otherwise the repeated scaling is very uneven. The manual says that I can change “F-curve modifiers”. However, when I hover over the wrench/spanner icon, it says “F-curve modifiers are disabled”. Is there any workaround?

The best I have found is to use bezier interpolation, and create extra unused frames at the end. This sort of works, but I would rather have full control of the curves for next time.

Thanks for any suggestions. (Blender 2.76, Linux Mint 64 bit)