F12 and render button give different renders *solved*

when I render a scene with F12 (or CTRL F12 for animations) it looks different from when I render it by clicking the buttons: with buttons it looks darker.

the difference appears only (noticeable?..) with this scene, and another one that looks like it.

why is there a difference and which one is the correct render?

first: F12 second: button

Attachments



Maybe the only way to tell is F3, then look at that render.

Maybe you have your lights on different layers and render layers does not have all the layers turned on?

Just guessing…

Atom, you’re very good in guessing. You should go to a casino! that was exactly the problem and another problem has been solved with it too.:D:D:D

I thought F12 did exactly the same as the render button. the hotkey reference says that F12 renders the scene, but it doesn’t note anything about a difference with the renderbutton. so i think there’s either a documentation error or a bug.

THANKS!!!

btw, jenniferblender: F3 is to save renders, so it is already rendered when you press F3. my attached images were both saved with F3.

marijnator,

I don’t think it is solved - I am seeing the same thing. In a scene I am working on, layer 2 doesn’t render when pressing render, but it does render when pressing F12. I am using 2.47 on Ubuntu 7.1

EDIT>> I can reproduce the error at will in the scene I am working on, but I cannot reproduce it at all in a new blend file.

A quick test shows that F12 uses the layers selected in the 3d View where the Render button will render the layers from the Render Layers tab. This will produce the effect if you have different layers selected in each location.

it is certainly solved in my case.

OBI_Ron, i think you’re mixing up two different kinds of layers: layers for the 3d view and renderlayers.

to clarify it:

Attachments


marijnator,

You are right - kind of. What I missed, was the little lock next to the 3d viewport layers. It seems that at some point, I unlocked in my current scene (default is locked). When the lock is on, the render layers will turn off and on with the viewport layers and vice versa. When unlocked, changing one does not change the other.

Another learning experience - that is what I love the most about Blender and this forum!

That’s what I get for thinking from memory instead of the GUI open in front of me. That’s my lesson learned lol.

nice tip, OBI_Ron. didn’t know that. (and a lot more with it, unfortunately:o)