F12 for Render does not work on Mac

When I click F12 I increase the sound volume on my Mac.

I have app shortcuts set up for Photoshop and Adobe Bridge, but I can’t do that for Blender.

Screenshot supplied: when I click the F12 button to fill in the keyboard shortcut I get the annoying error BOOP sound.

1 Like

Actually, I’m not getting the error sound.

When I type in the shortcut - press F12 - I just increase the sound volume. I can’t get it to work and can’t render.

I know I can check the toggle F1, F2… etc as standard function keys.

But I’d like to program them as app shortcuts.

Has someone succeeded to do that?

For this one also needs a menu item, e.g. …render

But I can’t see the render command menu item. Is there really none and can you only use F12?

There is one. In the Topbar, 3rd from the left: Render → Render Image (F12)

2 Likes

And like any operator, you can access it from the operator search, which is F3 by default

1 Like

Sure, but you can’t program that as an app shortcut.

2 Likes

Just press Fn + F12

2 Likes

Thank you for all your replies! I put all the info together here and mark it as solution for others who are facing the same problem.

TO ENABLE FUNCTION KEYS ON A MAC THERE ARE TWO WAYS:

  1. System preferences - keyboard - check box “use F1, F2… etc as standard function keys”. If you want to increase/decrease sound volume, press fn + F11/F12

  2. Press F12/fn

For myself I decided it was best to check the “use F1, F2… as standard function keys” at the beginning of each Blender session and uncheck it when I close down Blender.

1 Like