F2

add-ons

(ng-material) #122

all of a sudden this addon doesn’t work for me anymore. I thought it was something to do with my current version of blender, but I opened older versions of blender where it worked fine, and it doesn’t work in there either now.

tried opening factory settings, not working. any idea what it could be?


(Toxx) #123

Hello,
I can’t make the addon work with blender 2.72.


(albinooscar) #124

This addon is not working with 2.75 either.


(eXKR) #125

As far as I now, the most recent version of this plugin is bundled with Blender official release and it’s working for 2.75…


(krokodil) #126

Try to add shortcut to:
User preferences - input - 3D view - Mesh : mesh.f2



(gavner25) #127

Can someone help me here. If i select the edges of a square a press ‘f’ it works fine, but if i select the vertice in the corner it dosnt create a square only half of the square (triangle) for some strange reason. Am i doing something wrong ?


(1D_Inc) #128

Yes. F2 addon is not enabled in addons section. This behaviour is default, and it was introduced after F2.
Also recommend to enable AutoGRAB function.

Attachments



(PLyczkowski) #129

Feature request: make the add-on work with the auto-merge feature:


(Meta-Androcto) #130

hi, your welcome to add additional features & post to https://developer.blender.org/maniphest/project/3/type/Patch/
this addon is currently orphaned


(marksto) #131

F2 addon has conflict with Hard Ops addon in 2.78-version? Can someone confirm this. It is sad!!


(rrtk) #132

Those are not connected, remove all old hops files and download the latest one(for 2.78).
If it doesn’t help reset blender preferences to default and enable hops and F2 once again to check if they work now.
If it still doesn’t worksend me priv with full error description.


(marksto) #133

Sorry, I can`t post to your priv due to URL address. But here is the error message:


I use latest blender version 2.78.4 from to day and both F2 and Hard ops are the latest. Oh, and win10/64. My console message has nothing meaningful.
Thank you for your answer. However in version 2.77 F2 addon works perfectly fine, without Hard ops though.


(rrtk) #134

this is a problem with Your preferences.

again
remove all old hops files and download the latest one(for 2.78).
reset blender preferences to default and enable hops and F2 once again.


#135

Hey guys… I was wondering if I should install the addon or does it come in Blender by default?

I don’t get the exact same behavior I have seen others get. It doesn’t seem to create quads from a single vertice.

Edit:

Ok got it now it seems I had to deactivate the F keystroke that comes with Blender because it does not do the same.


#136

I am getting an odd behavior when creating a new face from a single vertice. It seems the vertice gets stuck to my mouse (G) and it won’t release until I right click my mouse. Is that normal? It really slows things down. In the tutorial video posted it looks like that is not happening.


(fiendish55) #137

F2 addon autograb function on?


#138

Wow how stupid not checking the addon preferences. Thanks a million!!


(Renderluz) #139

I found some odd behavior, I downloaded the latest build from the bleeding edge, and F2 was not working properly.

What happened was that I grab an edge surrounded by faces, then I would hit f to fill it, but nothing happened, then if I exited edit mode, upon re entry to edit mode, a new face was created were it was supposed to be the firs time around I was in edit model, as if F2 needed me to exit and re enter edit mode to create the face.

:Edit:

I was wrong, what happened is that part of the functionality of F2 is part of how Blender works now a days, that is, the capacity to fill a row of empty quads hitting F repeatedly like its shown on the Cg Cookie video I linked, the capacity to create a quad from a vertex however is not, I submitted a bug ticket to the blender bug tracker, as I realized the problem is still present even when I go back to factory settings and I turn on only the F2 addon, at first I thought is was turned on, but that’s just Blender being how it is right now, I guess the devs, added most of what F2 does to blenders native central system by now, except the vertex to quad.


Old rant of the subject:

So I went to the addon folder and deleted the addon completely, and to my surprise, it still works… maybe the devs added the functionally directly in the entrails of blender, so the addon is no longer needed as an addon?, still I found all this to be strange, so can some one else check this? delete the addon from the addon folder, then see if the functionally is still operating? the build Im using is: blender-2.79.0-git.980a864-windows64


(Renderluz) #140

The test I was doing with the addon is the exact same thing Ken is doing is this video: https://youtu.be/ImSNOuvkKsw?t=90


(Renderluz) #141

Upon more testing I realized this particular function where you fill a row of faces hitting F, is by default on in Blender, even when the addon is not preset, however if you try to create a face from only one vertex, (another function of F2) you get a triangle instead, still Im a bit confused as to why this is the way it is.