Face Merge and Knife

Hi guys. I’m new to blender (but not 3d modeling). I’ve been using it a few weeks, and I really like it, but I’ve been having a bit of trouble with some of the tools.

Here is a set of cement steps I was modeling yestersay. I had a lot of trouble using the knife tool. I used it like the documents said, but instead of cutting a clean line across a face, it got triangulated and split like the below picture.


So after that didn’t work, I resorted to cutting new edge loops into my shape to make the faces needed to extrude my steps. But now as you can see in the image below, I have a bunch of excess faces there. I would like to merge them and end up with just 5 quads going across. How can this be done?


I have the same problem with all the buildings in my scene. I keep adding edge loops to make spaces where I can extrude door and window holes, and ending up with extra faces all over the place that both makes further modeling more complicated, and increases my polygon count when I want to stick to a set budget.

Merge vertices - [Alt+M] - specify where to merge. Or use Snapping mode and AutoMerge editing ON
Convert triangles to quads - [Alt+J], or simply [F] when two triangles are selected.



That works on one quad, but would it work on those steps? Seems like I’d just be making a bigger mess of it, because those merged vertices would be apart of the adjacent faces? I’ll give it a try later on when I get back to work on it.

This works on mesh objects in general :slight_smile:
Just remember that when you use the Knife Cut blender will try to keep all polygons triangles and quads. The result of the cut is pretty logical once you understand how it works. I think the Manual explains that tool very well.

I wish it would keep it at quads. I can’t cut a straight line across a plane without it getting triangulated, and the cut looking nothing like what I drew.

The screenshot above is an example of me just trying to cut a straight line across. I draw my line with the knife, hit enter, and I get random triangles.

You need all the edges and faces you want to cut selected, the knife will do squat on unselected edges/faces.

Are you trying to use Ngons? It is not possible to make the above stairs example with only 5 quads (true quads) on the side. (as a solid object anyway) From this perspective you do NOT have any excess faces.

I have about 11 too many.

And yes, it’s perfectly possible. I constuct this stuff all the time. I could also construct that in blender if I wanted to go about it backwards, by extruding edges after I merged a few quads.

No, it isn’t possible. Blender doesn’t have N-Gons (faces with more than 4 vertices). Look at quad 1 and where it meets quad 2 in your sketch. At the bottom, all is well, but the top of quad 1 can’t be attached to anything on quad 2 if you eradicate that “extra” geometry.

For this kind of stairs you can save a lot of time by using closed bezier curve with extrude option on (see the image below)
If you want to make diferent type of stairs please give an example.


The word ngons gets thrown around. Sometimes people say it to mean a face that has more than 4 sides. I create this geometry all the time in other editors, but they don’t care how many vertices are in any shape.

So what would happen if I created all the planes and merged them as a single model? Would Blender triagulate it, or would I get a model that was a collection of freestanding quads?