Face Rigging Issues w/ BlenRig 5

So, I’m currently trying to rig a model from Mass Effect (it was converted for SFM, but no compatible rigs existed, so I moved work entirely to Blender) using BlenRig 5. I’ve been following the tutorials that were uploaded to YouTube and have successfully arrived at the part involving rigging the face: https://www.youtube.com/watch?v=Xnl7nQz7T3A
I had problems in the past, but all were solved within a few extra tries. This one is different and I have no idea how to solve it.

The problem here is that two of the rig controllers are deforming parts of the mesh that they shouldn’t have any influence over (at this point in the rigging process – at least, according to the tutorials), mainly the “maxi” controller for the jaw. It seems to be controlling: one vertex on the chin, most (or all) of the teeth mesh, the backs of the eyeballs, and the lapel of the shirt collar. The “head_mid_ctrl” also influences part of the neck, but I’m not sure if that’s a separate issue.

You can see this here: http://imgur.com/n977Cl5

This can’t be an error in weight painting, since I haven’t even gotten to painting any part of the head for facial controllers, yet (that’s what I was about to do when I discovered this problem). The only bone having anything to do with the head that has designated influence (weight painting) is the “head_def_mstr”. I also don’t think it has anything to do with the mesh deform cage, but I honestly don’t know much about BlenRig 5’s setup beyond what I’ve learned in the tutorials, so far.

Here is a link to the .blend file, if anyone wants to inspect it directly: https://www.dropbox.com/s/ajiwiy5fjti47z9/Shepard.blend?dl=0

If anyone can help, you have no idea how much I’d appreciate it!


You have little to no vertex weights on the facial deform bones.

Correct. The tutorials had me only place the bones, but begin weighting things like the hands and fingers, which I just finished doing. The next step was weight painting the face, but then I saw those deformations happening. The reason I’m asking for help is because they should not be doing that, as I haven’t assigned any vertex control to those bones/controllers (that I’m aware of), yet.

Are you saying that weighting the face to the deform bones will fix this?

I’d really like to be able to properly finish rigging this model using BlenRig, rather than start over from scratch with a custom rig, if possible.

Here’s how I would diagnose it. Make sure you have checked your display modifier in edit mode and the adjust edit cage modifier in your modifiers. Go into pose mode. Pull out the offending item to a absurd amount. Now turn off the display icon on your modifiers one by one and then back on and find the offending one. In your case it is the mesh deform modifier. That is your issue. If you go into edit mode on your mesh and turn on show weights and then click on your vertex groups you have NoMDef, and then select your group while your mesh is in edit you will see that you have vertices that are not weighted to that group in your head. Check by selecting the vertex and review the show weights. So that is your issue. Fix the weights on that vertex group so that your mesh deform is not using it.

Well, I think your advice has definitely stepped me in the right direction, so thank you. But I’m still getting some trouble.

First, what I did was simply assign the misbehaving vertices to the NoMDef group, which then resulted in a bunch of different vertices acting up, instead. I tried to correct those, as well, but that led to a depressing chain reaction of everything going screwy.
So, then, I reread your post and followed it more exactly, painting the misbehaving vertices, rather than simply selecting them and clicking the “assign” button. That seemed to work. I retained all previous rig functionality (nothing went haywire) and I managed to get the eyes and mouth to stay in the head and not move improperly. However, I’m still having trouble with the lapel/collar of the shirt. When I try to paint that, it does this: (ignore blinking timecode – also, I’m hitting ctrl-z at the end) http://imgur.com/3JEA388