Face select problem with Occlude Background Geometry

Hi all,

I’ve come across a strange problem and I suspect it may be a bug but just to be sure i’ll post here before submitting it.

The problem is that I can’t select faces by clicking in face select mode when ‘Occlude background geometry is on’. I can use all other selection methods except right click (which is really what I need). I was using the Blender in the ubuntu repositories and had the problem then and I’ve since upgraded today to the latest version but still the problem remains. I am definitely not in wire frame mode by the way. I asked in the IRC chat room and a kind fellow tried to help but he wasn’t sure either. Any suggestions?

I’m using latest Ubuntu (8.10) and latest Blender (not svn). I think that’s everything. Oh and this happens in all files and have also tried to restore to factory settings but with no luck.

Thanks in advance,

PS: I would try to test the latest svn but I can’t get any of them working (blender program just doesn’t run, no errors, nothing).

I have no problems selecting under 64-bit Ubuntu 8.10 and 2.48a, perhaps it is a graphics card issue? I have a Nvidia card. So, when right-clicking on the face’s midpoint dot nothing happens at all?

Thanks for your reply.

I can’t imagine it’s a graphics card issue because even when I right click the face (or the face’s midpoint) and hit the G key to test to see if it moves and perhaps it isn’t showing up pink nothing happens. I can select faces fine with OBG turned off. It’s just wierd.

No problems here either. Im running windows.

Try ctrl>right click to select

If that works it’s the graphics card

That’s weird.

I have no problems with face select on either 2.48a official release or svn versions on ubuntu 8.10.

It’s also kind of strange that you can run 2.48 but can’t run any svn versions on the same box. Are you trying to start it from the command line or by double-clicking because usually the command line will give you a clue as to why it isn’t working.

Try starting blender from the command line and see if it spits out any errors when you try to select a face. If not and it isn’t something simple like you accidentally clicked the ‘disable face select in occlude hidden geometry’ button then you’d probably have to run it under a debugger to figure out where things are going wrong.

What kind of graphics card are you running anyway?

In response to shatter, Ctrl RMB doesn’t work either. I am pretty sure it isn’t a graphics issue. As for what graphics card I have I am using S3 Twister Graphics (or at least that is the name of the driver under windows). No output in command line either. This is just strange.

oh okay

But just so you know if it was a graphics card issue this wouldn’t be a valid way to test it:

“when I right click the face (or the face’s midpoint) and hit the G key to test to see if it moves and perhaps it isn’t showing up pink nothing happens”

blender somehow uses the graphics card to actualy select the face, but ctrl>right click is an alternate way of selecting using cpu??? or something.

Right ok. Well selecting the face with the lasso/border/radius/all other select tools select faces fine so perhaps that rules that out. Or not I don’t know really.

Anyway I tried on windows blender (on the same machine - dual boot setup) and can select faces fine with OBG on.

Just as a side note, the version of blender I am running was downloaded from blender.org, and I double-click the icon to start it- I didn’t install it from a deb or synaptic.

Yes me too.

I know this sounds absurd but why dont you try a different mouse?

Tried with both touchpad and 2 external mice.

Ok I’m guessing this has to be a bug. Any other suggestions before I submit the bug?