face smoothing with boolean etc modifiers?

I’m trying to use a modifier stack that has a subsurf and a boolean. Also possibly a decimate. My problem is that the subsurf seems to preserve my face smoothing settings, but the others don’t. Decimate seems to leave every face as solid instead of smooth, no matter what I set the actual faces to in the model. I’ve even tried autosmooth, but it doesn’t help either.

I have the same trouble with boolean difference. The new faces created by the boolean are always set to solid, even if every single face of both objects involved in the boolean is set to smooth.

Of course, I could “apply” and bake the modifiers in, but that defeats the purpose of having them as modifiers.

I’m brand new to Blender - like about one day - so I guess I must be missing something about this. How can I control face smoothing of modifier created faces when I have applied a modifier stack to my object?

Thanks a bunch for any help to a total newbie!

Edit - this is with 2.49, which is the latest version I can apt-get.

I don’t get what you mean but hit Set Smooth to make all faces smooth. Hit Set Flat to make them flat. If you want to have sharp edges, first hit set smooth, then go into edit mode. Select the edges you want to be sharp, press Ctrl E. Select Mark Sharp. Leave edit mode. Go to the modifier stack and add edgesplit. Turn on Sharp edges and turn off Edge angle.

kingalex11235: Since the faces don’t actually exist (they are being created by the modifier), you cannot use set smooth on them. You can only set smooth the original faces you made on which the modifier is operating. Hence my question: if the modifier does not preserve the smooth attribute, how do you control which of the generated faces are smooth?

All the faces created by the modifier do exist, they are just not editable. You can set smooth again after the modifier is put on to make the new faces smooth. However if you want to make some of the new faces flat and some others smooth, you must apply the modifier…

Thanks for trying to help me - but for some reason it doesn’t work for me. I can apply smooth just fine to faces I make directly. It even works for faces coming out of the subsurf modifier. But for faces generated by either decimate or boolean modifier, it does not work. The faces are just flat no matter what.

I don’t know why… :-/

Ok here is a screenshot of what I mean. First I created an icosphere of subdivison 3, and set it to smooth faces (b5.jpeg). Then I just applied the decimate modifier, and left it at the default of 1.0. That’s b6.jpeg - you can see that my formerly smooth faces are now flat shaded. Nothing I can figure out how to do makes them smooth again.

The same happens to the boolean modifier. Unless I can figure this out, it makes most of the modifiers useless to me :(. I’m OK with an “Auto Smooth” effect on the result of all the modifiers - I’ll just set it at 30deg and be happy. But it doesn’t work…

I’m a total newb at this, and I feel I must just “not get it” yet.