Fade GE objects in 2.5

Hey, I need some help fading an object out in the blender 2.5 game engine (GLSL).

I have an object with a material, and an image texture with alpha transparency. In 2.49 I used to use object color and colA to fade the object in the GE. I’ve tried using the same technique in 2.5, and it fades in and out in the workspace, but when I try it in the GE it is completely invisible. Have I done something wrong, or is there an alternate way to fade textured objects in 2.5?

Object colors are still working with Blender 2.5x . You must have done something wrong. At the moment you can only use object colors, but the developer are working on GLSL material colors for the BGE.

Attachments

alpha_change25x.blend (521 KB)

I think it might depend on whether you have chosen Material or Data in your material slot. I think you need to choose Material to use r,g.b,a in python scripts.

Also, please try your file in Blender 2.57 as well. 2.58 introduced some regressions with object color in the BGE, which have been fixed in trunk.

Ok, I tried it all over again following that .blend file and it works this time, thanks for all the replies. 2.5 is looking pretty good right now.

how do you guys add the values R;G;B;A color values?

  1. Select the object.
  2. Chose in the “Properties” window the object tab (cube symbol).
  3. Go down to “Display”
  4. Under “Display” you find the “Object Color”
  5. Move the mouse over the object color feild and press the i-key to make a key frame.

To use the object colors instead of the material color, you must select in the material tab under “Options” the “Object Color”

@ HG1 is there a more detailed tutorial for that ? tnx

You must read carefully.
5. Move the mouse over the object color field and press the i-key to make a key frame.
You find the object color under object (tab with cube symbol).
6. Change the frame number.
7. Open the object color field and change the alpha value.
8. Make a second key frame of the object color.

No there is no much more detailed tutorial.

Again. You must read carefully. Look at post Post #7
To use the object colors instead of the material color, you must select in the material tab under “Options” the “Object Color”

Or look at the video at 1:45.

Attachments

Not Fading 2.blend (311 KB)