Fade out with alpha texture

In my scene I have several partially transparent tubes (ztransp), but I want to apply a texture to them so that they fade out to being completely invisible so you can’t see the ends, but for some reason no matter what I try it WON’T work. I’ve tried painting textures, UV mapping, procedural, setting the object to full transparent to fully opaque trying to get the texture to show up SOMEHOW, but nothing I do has any visible effect.

I have tried all the methods on this as well: http://wiki.blender.org/index.php/Doc:Tutorials/Textures/Use_Alpha_for_Object_Transparency

I thought this would be very simple and easy but it’s turning out to be a nightmare, any help anyone can give would be greatly appreciated.

you need to add an IPO curve to drive the alpha value
see IPO edtitor for thsi effect


Sorry, might not have described that very well, but I didn’t mean having the whole thing fade out over time, I know how to do that just fine. I want to have one end of the thing visible, and the other end completely transparent, the only way I know of doing that is a texture, but that’s not working. I can’t figure out what I’m doing wrong.

Is the transparency of your tubes made with the alpha value of the material or the alpha values of the texture? I guess you control the alpha with the texture, else it is indeed just done by controling the materials alpha via IPO.

If the texture controls only the alpha value you need a IPO for the dVar. If it´s 0 the tube is invisible. If it is 1 it uses the alphavalues given in the texture.
The material alpha has to be 0 for that, ztrans on.
Be aware though, that specular highlights will still show, so along with making it transparent you might have to animate the material´s specularity settings.


I made you a file :slight_smile:


It first uses a blend texture and trasparency animated to make the pipe half invisible, half visible
and then uses dVar to make it invisible at all.
Also look at the UV layout, which fits the blendtexture.

hope that helps :smiley:

It works! Thanks a ton for the help arexma, you’re a lifesaver. :smiley:

Arexma gets a cookie :slight_smile:

All for one, blender for me :smiley:

I forgot to mention, I also turn down the specularity in the first part where I blend in the blendtexture. If you remove that, you´ll notice that the invisible part still has specularity although it is invisible.
On the other hand, If you turn down the spec, the visible part lacks it then.

I haven´t found a solution yet for that one… making it Shadeless is also not an option, and applying the texture mirrored and affect the specularity is also not satisfying.
Anyone has a technique there?

Buried at the bottom of the RayTrans panel is a slider labeled SpecTra for Specular Transparency – give it a zero value if you want the specular to fade to naught along with the alpha/dVar.

Though in the RayTrans panel, it also works for ZTrans materials.

TY ymmd. =)

or adjust the fresnel and fac sliders…but the render time grows and grows.:slight_smile:

B/C raytraced transparency is still off. We talk about z-transparency which involves no raytracing at all.

Yes, keep raytracing off, but adjust the fresnel and ac sliders…It worked for me.

Yes, it seems a number of the RayTrans settings affect ZTrans as well. Handy for certain effects.