Faith - Adverture RPG


(Lucrecious) #1

Hey everyone, I am happy and proud to present…

Concept:
I was in want for a game with a mix of serveral games to make this one, of course, this is my 1st real game project, so it’s not an actual mix between this games, but it’s good enough for me :slight_smile:

The Legend of Zelda (The type of RPG)
Shadow of the Collosus (The Combat)
Final Fantasy (The Style)

Story
The story is actually really complicated to follow, since this is the first game, the objective is simple, it’s said in the beginning of the game, I am planning to make a sequal in the future when I have more experience, so look out for that…

Basically, a guy gets lost in a forest… A huge forest, called The Whereabouts Unknown, where many person go in, but never come out. For some reason, this person was running away from something and was lucky enough to find a way out, finding himself in a village ruled by an Evil God, named Sagon.

Play the game, and the history will clear up the idea…

http://i355.photobucket.com/albums/r471/LINKXGL/another_faith-1-1.jpg

Controls: (There are many)
Mouse = Camera Look
WASD = Walk
WASD + Space = Run
Ctrl = Put in/Take Out sword
T = Talk/Read Signs
Climb = W + something to climb (Can be a boss or what looks like a ladder)
Left Mouse Button = Sword Combo
Right Mouse Button = Stab the ground
Enter = Pause + Save Menu

That is all :slight_smile:

Features:

  • Full Animations
  • Dialogue System
  • Huge bosses
  • Many Puzzles
  • A village with people to talk to
  • Everything fully modeled and textured (Except for some village people)
  • Cutscenes
  • Cool Music and some sound effects
  • Save and Load
  • Hopefully 30 minutes of Gameplay :cool:
  • A bunch of other stuff…

http://i355.photobucket.com/albums/r471/LINKXGL/latest_scene_demo.png

Videos:
Update Videos
Playlist of updates videos since I started to make the game, you can see my working progress… kind of…

Trailer
A really cool trailer, but I’m going to upload another trailer with better font… Yeah, don’t worry, you’ll barely notice the difference…

Downloads:

.blends

81.5 MB

Faith .zip (Mediafire)
Faith .zip (FileFront)
Faith .zip (FileDropper)

76.0 MB
Faith .7z (Mediafire)
Faith .7z (FileFront)
Faith .7z (File Dropper)

NOTE:
If you want the .blends to have music in them then you need to download this version of blender:
Blender 2.49b
that has more sound support, like .ogg for the game engine… The link above leads to a thread with many versions, for Linux, Windows, but not for Macs… :frowning:

Setup
The setup is basically a stand-alone version of my game, so any person can play it, this is not for looking at my code or data, just to play the game :slight_smile:

96.9 MB
Faith Setup (Mediafire)

For older versions of the game you can check my work in progress thread here:
Blenderartist Thread

Credits:
They are at the end of the game, but I will post them here also:

Lead Programmer
Luca Duran (Linkxgl)

Lead Modeller

Prip

Lead Animator
Kmcroxton

Village Designer
Excalibber

Lead Level Designer
Linkxgl

Concept Artists

Andrei Betlen (Gamerboii)
Linkxgl
Excalibber

Sound Artist

Joe Cavers

Special Thanks
Andrew-101
TheDave
Cray
PhilB
Social
forTe
Blendmaster1024
Sambassador
B3D00
Blendiac
vanlangjahr
LordM
Dim
MrHippyGuy
Ugalay Buga
Minifig

Hopefully I didn’t miss anyone…

Notes:
I didn’t feel like making more characters for the town so don’t judge the look of some of them, a lot of them look like total crap, but I rushed through the ending of the game because I was bored and I’m tired of working on this game!

Hope you enjoy our game, and that’s it!

Thank you,
Linkxgl


(BurningSniper) #2

wow your done so soon? well thats good to see :slight_smile: i would download it but i dont really have the time right now, maybe later… did you get those npcs in the village? i remember you had some trouble with that.


(Lucrecious) #3

I tried, I only got 2 ncps in there -_-, the other ones look like total crap because I made them in like 3 min.

Done so soon? man…

I don’t think 1 year for a game like this is soon :wink: ha ha Well, at least for me it’s not… ha ha

Thanks!


(stevecameron) #4

Good job man. Works quite well, although the combat is a bit sluggish. Also the sound doesn’t work for me :frowning:


(DividedSpleen23) #5

Um. I can’t get the game to work. I’m on a mac, and I downloaded the filefront 80 MB zip. I opened it in blenderplayer 2.49 and it doesn’t save any games I create. Do you know whats causing this?


(juniorsla) #6

very good friend all this
your game is an awesome game
bye xD


(Hellooo) #7

YAY YAY u finished Woot for you xD


(monkeyuncle8) #8

you need to help me with my game


(Lucrecious) #9

If you downloaded the .blend, the sound doesn’t work because you need:
http://blenderartists.org/forum/showthread.php?t=160447

That version of blender… Download it and see if it works when you play it with that… :slight_smile:

weird, I haven’t tested the game out in any operating system except for windows… I think it’s because it doesn’t know where to save the file…

I don’t have the time to re-upload it or anything, but the game isn’t that hard, you can probably beat it in like <30 min if you really try :wink:

But I want to be done with the game so that’s how I’ll finish it :confused:

@ Everyone:
Thank you for the comments, I appreciate it :wink:


(DividedSpleen23) #10

The game won’t let me start without a save file, so I can’t play on “expert” mode. :slight_smile:


(JESUSFRK14) #11

Downloading :slight_smile:

Submit it: http://blender-games.com :wink:


(gmDannz) #12

looks good…say how long did it take you(everyone who worked on it aswell) to finsh this game?..just curiose.


(Lucrecious) #13

he he, the progression was slow, so it took 1 year… Not kidding :stuck_out_tongue:


(ShadoX) #14

Certainly neat but it lacks some sound and some visuals ques as to where you are supposed to go or whats going to happen. I only made it to that cave where the floor would constantly fall down beneath me. Eventually I got stuck, because I was standing at both the floor and the falling ground and ended up constantly falling, despite standing on the regular floor… Thats where I quit. (would be better if the places that would fall down would have a slightly different texture.

I also would suggest making those floors fall down and not only go down b a inch. At one point I was almost over a piece of falling floor but ended up falling down with it. The problem was that I was still on the piece, standing and normally would be able to just climb back up on the regular floor… I have no idea if there was a climbing button so yeah…

Its pretty good, but lacks a little bit of polish in the design… Still… Great job! :slight_smile:
[edit] About the sound… I was using 2.49… Goes thats the reason for only having 1 sound… xD


(Lucrecious) #15

Yeah, ha ha, it was my first real game so you can’t expect much. There is a slightly different texture :stuck_out_tongue: It’s just barely noticeable. Just walk slowly and look for a deformed texture (that doesn’t connect with the texture). Once you get past that the rest is pretty easy, I suggest you finish it :smiley: There are 3 cool bosses, :wink:


(LeSanglier) #16

Hello,

I got a little probleme with this game : I can not play, that is to say, I enter my name and click on “play” button and there is nothing…
The errror message :
samuel.fwu does not exist!!

The “New File” menu does not work…

How to resolve this problem ??

Thanks in advance !! :slight_smile:

I am under Kubuntu 9.10 and I use Blender 2.49b with python 2.5


(marcecho) #17

I haven’t played this game but as I watch the trailer, I think its pretty good. To be honest, I’m currently downloading this game. :slight_smile:


(Frank_robernson) #18

better then a lot of people who give up and fail. well-done.


(Lucrecious) #19

wow thank you guys, but no need to be nice, I know it was a fail :stuck_out_tongue:

@LeSanglier: It’s self explanatory, it means that your file doesn’t exist, and yes, that means the New File menu is putting your file in a different folder where it is being put. The only possible way to fix the problem, I guess, would be that, when you save you file, you’d need to have a certain directory to where to look for it. Unfortunately, that’s what I thought I did, and I guess I didn’t.

The other problem might be to your using the wrong version of python. Try using version, 2.6, I’m not sure that it will fix the problem, but it’s worth a try :slight_smile: Good Luck and thank you for downloading my game :wink:

Thanks to the 3 people who commented, I really appreciate it,
Bye!
Linkxgl


(Mysteriousblend) #20

LinkxGl

Congratulations on the completion of your game!
I downloaded it to give it a try, but when I try to run the exe I get an error that says it can’t find blender player.
I have two versions of blender installed. Blender 2.49 and Blender 2.50a. Neither is on the same drive as the game.
what version of Blender player does it need? I really thought blender player was bundled in game engine .exe files, Is that not right?