fake, flat looking hair

hi everyone.
i’m creating a character and the hair looks like rubbish. can anyone tell me where i went wrong?

i’m useing a hemi light and have children apllied.

i’m useing a hemi light

Why ? The hemi light casts no shadows so you’ll get a flat looking image.
Watch some tutorials and see how that make hair.

i tryed the sun light and it looked awful and i can’t get the spot lights to work. i tryed googleing how to make hair in blender 2.5 but only stuff for 2.49 came up.

Look on the blendercookie site there are hair tutorials for 2.5.

i tryed googleing how to make hair in blender 2.5 but only stuff for 2.49 came up.

For a google search always have blender 2.5 as part of your search request, such as this link http://bensimonds.com/2011/02/17/hair-in-blender/ which was the first result I just got with a google search

i changed the lighting an it looks ok but now i’m getting weird results with my character’s fringe. here’s a render and a screenshot.


Using a blend texture mapped to the particles alpha makes a huge difference too. Additionally, if you want to avoid fill and rim lights, you can use the same or similar blend texture and multiply it to the diffuse texture / color.

i tryed to do that but it seemed to make no visible diferance. dose ony one know why my character’s fringe looks like it’s been shaved off?

I don’t know what happened, but you could use the grooming tools to grow back the missing hair. also, you could add a texture with some variation, a bit of value noise maybe, so all the hairs are not the exact same color. this can add a more realistic look.

Is it possible that the base mesh had the normals reversed in that area? Alternatively there is an option to kill particles when there is a mesh impact, take a closer look at that.

like i said, i have tryed makeing a texture but it dosn’t seem to work. i’ll cheak the normals but i’m pretty sure they’re all the right way. i haven’t realy looked at the kill particals but it tryed it once on a diferant model but it went all weird.

I have tryed that but it made it worse. dose it make a diferance that i had children set to simple? it looked to puffy with the other settings. interpoled is that the right name?

Take a look at a few of these http://matrep.parastudios.de/index.php?p=9 (search for hair if the link didn’t do it for you) If that doesn’t help, let me know, I can pull a material from an old project and post a .blend for you. Outside that, I have no other ideas where your bangs went.

Just as another thought for you, I personally dislike particle hair for all the reasons you’re struggling with. What I like to do when I need it is use it to create a texture, then make poly hair from it. So I create a flat plane, make hair off it and place a camera perpendicular to it. I then get my hair looking nice and render it to look like strands. I save the render as a texture that then gets UV mapped to other planes that get extruded where I would have otherwise combed the hair. The same setup then can also generate an alpha map… if that makes sense.

Also, one other thing you could do to help us help you is make a new .blend and just Append your hair material and post it here for us to look at. It might be that your hair is correctly set up and it’s very possible it’s just the lighting setup. I definitely recommend a rim light and at least one fill to get the particles to look alright.

One final thing for awareness, the Blender “Bounce and Tumble” book (even though for 2.49b) has a very nice chapter on particle hair, but of course that costs money.

you were right about the normals, they were reversed there for some reason but i still can’t get a good texture. i have considered useing the plane and textures method but it’s for a short film i’m makeing so that wouldn’t work, would it? i am starting to get better looking hair now but i do have some wierd looking parts.