Far Cry: problems starting game

Hi guys.
I have recently bought Far Cry, but I’m having problem with it.
I installed it correctly, my computer fits the system requirements…
BUT when I launch the game a screen appears for less than a second and dissappears while the dvd is turning round. After a few more second the dvd stops and nothing happens.
Also, when I run sandbox, I get this error:


CRITICAL EXCEPTION
Code - 0xC0000005
Address - 0x001B:0x38049DA2
Module - <Unknown>
Description - EXCEPTION_ACCESS_VIOLATION
Attempt to read from address 0x00000000
The memory could not be "read"
Call stack trace -  
    2) function=0x38049DA2
    1) function=0x0

I’m confused here… I can do everything else but these fail and according to the installer I have the latest DirectX installed.
Can anyone provide help?
Thanks in advance, guys!

I tried Far Cry about a year ago, and it used to freeze on my nVidia card. Read on their site, they may mention something there.

I found a handy Java application which told me exactly what the problem is.
The problem? ONE tiny little feauture on my graphics card which is missing which prevents me from playing the game… AT ALL!
The site is: http://www.systemrequirementslab.com/
Does anyone know a work-around for a missing “Video HW Transform & Lighting” for a Mobile Intel® 915GM/GMS,910GML Express Chipset Family (Intel® 915GM/GMS,910GML Express Chipset) video card?

Even if you get it to run I don’t think that you will get satisfying framerates.

BUT I can recommend simply mailing the user support.
The guys at CryTek are very kind and they know a lot of workarounds, and helped me out more than one time.

Well, T&L isn’t exactly a “tiny little feature” and I think that with your video card your framerates wouldn’t be playable even if you got it running in software T&L.

that’s integrated graphics right? sorry, probably not going to cut it in farcry. I recommend buying a graphics card a bit better than that. I play farcry on my laptop (1.5ghz, 384mb), and it has a 16MB nividia geforce 2, and it is extremely playable for me. that’s better than an integrated intel POS though.

hardware t&l is extremely important especially with graphically intensive games such as farcry. like others said, i doubt you would get playable framerates even if you got it working.

farcry used to crash a lot for me too (not at startup though). i installed the 1.3 patch. also switched the renderer to opengl (this usually helps the framerate for nvidia cards). just look for system.cfg or something in your farcry folder, and change the render field from “Direct3D” to “OpenGL”. i’ll go in to more detail if you like.

not sure about this one, but you might want to try switching to opengl. iirc, direct3d gets pissy when you don’t have a feature that the application asked for.

Hi
Have a look at www.crymod.com. Crytek’s modding portal with awesome community support.