Fast Loop

I very much like how you implemented all the various forum suggestions! Though I am running into quite a few bugs in 2.92 using the latest version, downloaded an hour and a half ago:

  1. When entering edge slide mode, I seem to get stuck in the mode, even though I change tools. Maybe there could be a preference where pressing ‘Q’ would just use Blender’s selection tools and exit Fast Loop? Seeing as this is so hard wired in many user keymaps to either switch tools or use quick favorites. The selection tool does not select anything in this case, whereas the control key works fine for selecting.


    I am also getting errors outside the tool, in object mode (even in the properties panel and N-panel in Edit Mode) when switching to selection:

  2. If I open fast loop, I don’t expect it to enter any other mode than Single/ Multi Loop (in this case it opens with Edge slide active).

  3. If I am in edge slide mode, the 1, 2 and 3 keys change Vertex/Edge/ Face mode rather than returning to the Single/ Multiloop mode. Furthermore, invoking the edge slide (using “G” in my keymap, in the addon preferences) causes the bottom header to glitch out.

  4. Upon activating Switft Loop with a previously selected edge, switching to Edge Slide using “G” may also still keep the preview active for inserting loops and show as being in the Single/ Multi Loop mode.

This does not occur with spacebar, so I presume some of the introduced bugs have to do with the multiplicity of accessing the tools, some modes work well, whereas others don’t. For instance, if I am stuck in a certain mode, pressing spacebar certainly resolves the issue by going back to the insert loop mode.

  1. Sometimes you need an additional click-hold to slide edge the initial edge, seemingly to activate the tool
  2. Small one: the letters seem to be slightly misaligned on my end, therefore, the Q reads like an O.

Suggestion:
Could you add a user-mappable hotkey to toggle Set Flow, basically a hotkey to the pie menu item for persistent on/off behaviour?
I also find the W key for spacing very sensitive to input, could that be reduces a little?

I’m a little confused here. It looks like you are entering edge slide with the spacebar?
If so, you have to press the spacebar again to leave edge slide mode. Or am i misunderstanding the problem?

I’m not getting any errors no mater what I do using 2.92.

I agree. It should never be on edge slide mode even if it’s the last one. Because if it does start on that mode then it mean that an unintended action occurred.
I will make it fall back to single instead.

This is related to the issue directly above.
This should never happen once I force it to fallback to single.

Edit: I forgot to add that if you are edge slide mode, you cannot hop back to fast loop since it’s a separate modal operator.

I think that’s because there are two modals running at the same time. If you want to use edge slide please use it by holding down alt, or pressing spacebar if that option is enabled. Though it does have restricted functionality. If you activate the mode using the pie menu or (god forbid )the edge slide button in the million of other GUI panels(Because the UI gets a little buggy and requires some extra left clicks) it doesn’t have restricted functionality. I could make it so the space bar toggle invokes the operator with no limitations but I was worried it might cause confusion.

Yeah that’s because spacebar is cancelling the edge slide operator.
As with the other issues above this is just another case of the UI/UX being atrocious. :disappointed:

Yeah I’m not sure why that happens. It’s like the viewport isn’t getting events. It’s out of focus?
It happens when I activate the edge slide using one of the buttons in the millions of panels.
Is it happening for you in a different way?

These are just blender labels with blender icons (where they exist). I cannot change them. Sorry

I just need to make custom mapping a thing already. Still not sure how I want to do it yet though.

Have you tried holding shift to lower it?
Is it still too high by by default?
I’ll just add another user preference.

Thank you for the feedback. I appreciate it!

Is it possible to have an edge loop tool that creates the loop based off of selected edges and keeps the same shape as the selected edges. ?

EDIT: it would be like edge offset cut in C4D

I also found that I get “stuck” in the Edge Slide mode. I have “Q” mapped to box select and on other tools it always kicks me out of those tools and puts me back into selection mode (I use the Industry Standard mapping). When I use Alt + ~ to get into Edge Slide mode I can’t find a way to actually exit it, and hitting Q does nothing.

1 Like

Are there any videos showcasing this feature?

Right click on the mouse should cancel/exit the operator.

1 Like

Is that the same thing here?

Yeap that is sort of the same tool just works a little differently.

I need to rework the edge slide algorithm first. Right now it’s a simple version of blender’s native edge slide code ported to python. It doesn’t work with vertices with three edges.
Complete oversight on my part.

All good! I’ll keep an eye out, i use this addon a lot anyway. Thanks for humoring me :slight_smile:

Knowing that someone uses this addon a lot makes all the time I spent worth it. I’ll be honest with you, I didn’t make this addon for myself. I made it because I noticed that people felt that the loop cut and slide operator was lacking in certain aspects. I just took it a bit further. :crazy_face:

2 Likes

Honestly if you can get some other things working in it like in that forum post i would buy it and others would as well. just he offset edge cut feature would make me buy it lol. and i bet you others would as well you could have a free version and a payed one with the more complex things you need to work on.

Like dude not being able to loop cut cones was actually driving me crazy, i would have to make the top a super small face make my loop cuts then merge the face to center and then bam this addon now loop cuts cones.

I’m sure it drives everybody crazy.

Not just cones though. Tops of cylinders too

1 Like

Hi! Thank you for addon!
Wanna ask - is there any way to “lock” (any modal key or smthg) initial edge for determine loop cut. In messy situation is really hard to point mouse exactly on needed edge, especially in corners, where lots of edges meets and most of support loops needed… also noticed that backface edges takes into account to.

You’re welcome! I hope you find it useful.

That is certainly possible. I’ll add it to the todo list.

Yes. I’m not sure that will change any time soon.

1 Like

I was also a little confused myself, though it’s starting to make sense now thanks to your remarks. I have been testing (all) the various methods of accessing tools to see where it might fail, once it did.


The “G” keymap entry seems to be a legacy feature that introduces most of the bugs I am experiencing, this includes the preview showing for inserting a loop while in loop slide mode. Is it actually using the same operator as spacebar?

The other issues were likely caused by be accessing other tools while Fast Loop is active. At some point, when hitting Q (selection) and 1/2/3 (change to different selection mode), the UI appears to be frozen. So when I tabbed out of edit mesh (as it seems to be frozen) I can get rid of the Fast Loop UI and I was unaware that I had to press space to solve this.

The error message I reported appears if I press Q when Edge Slide is active, press tab to go to object mode, click once in the viewport. So it’s all related.

For me it then boils down to:

  1. Being able to exit the Edge Slide operator by pressing Escape key
  2. Freeing the Q key from the addon as it can mess up the operator from showing the UI, whilst Fast Loop remains to be active and thus freezes input.
  3. 1/2/3 behaviour in Edge slide > transition to Single/ Multi Loop, because it otherwise changes selection mode and causes some problems.

Using the default cube, I think a speed somewhere in-between the two would be best.

I can’t thank you enough for making the impossible possible with this addon, it’s definitely one of my all time favourite addons already! Especially now that I am aware of how I should fix me from breaking it :innocent:

1 Like

Yes they both use the same operator, but spacebar doesn’t have the edge constraint translation or the selection mode. They are disabled.

Yep that causes the error for me as well. Thanks for letting me know.

Including if it’s invoked with the spacebar?

I’m not seeing the issue with Q toggling select new edge loops in the fast loop operator.
Q shouldn’t do anything with either the edge slide mode or the standalone operator. But it does pass through input since it’s not used for anything. If that makes sense.

I will see what I can do for this.

It’s my pleasure. :slight_smile:

1 Like

I am very much accustomed to CAD software, where escape cancels any command at any stage, which is really convenient, so yes please even if it’s invoked with spacebar.

Okay that makes sense, sorry to keep hammering on this (it’s a bit difficult to explain as Screencast keys does not show me pressing Q when I do…). Despite passing through, Fast Loop does seem to interfere with tool switching on my end. Fast Loop’s edge slide remains active, so instead of selecting, it keeps sliding the selected loop. In Loop cut mode, Q is not registered by Screencast keys, nor does it switch to the default selection mode (I expect it to behave as though I am manually picking the select tool). It seems to be as though Fast Loop is not cancelled like it does when manually picking the tool.

E: Clarification: I am pressing Q when I pause near the end, prior to manually picking the tool.

1 Like