FBX Bundle

Thanks so much for the info.

Unfortunately I can’t find anything to hint at why these particular animations won’t work. The ‘Select’ animations mode just shows an empty list, even if I press the Plus button.

I’ve tried making new animations but they don’t show up either.

As far as I can tell the only option I have is to trash this armature and start from scratch, remaking all of the animations. I don’t know how to copy animations from one armature to another, and I don’t know what will cause FBX Export to completely fail.

A limitation of the select option is that it doesn’t work as an “override modifier” it has to be added to the “Export Modifiers” instead


Try enabling these two buttons to see errors in the animation.

2 Likes

Thanks so much @AquaticNightmare , this helps a lot! I’ve been banging my head against this problem for days.

I was able to track down some errant animation data by expanding each and every bone. Deleting those allowed me to export the animations, but there are still lots of problems with them. It’s definitely given me a lot to work with and I’ll spend more time with it soon and see if I can nail down the final problems.

1 Like

This is such a great addon. Wonder if we will get a 3.0 update. Hope the dev is okay. This hasn’t been updated in a while. :slightly_smiling_face:

I’m using this addon fine in 3.1 what needs to be updated ?

1 Like

Oh… My bad. Didn’t check out the thread. Clicked the link to the op’s website. Saw ‘‘Blender 2.8 not yet supported’’. So I wrote that.

Didn’t notice @AquaticNightmare helped port it to Blender 2.8 and is helping maintaining it.

@AquaticNightmare Thank you for updating this addon and fixing issues with it. My apologies for not checking out the thread

1 Like

is there a way to add a modifier that where instead of the objects being exported offset from the set point the bundle is exported with the objects origin at the set origin point so if i set the origin to scene 0,0,0 instead of the bundled objects being exported offset from that point each object in the bundle gets moved to scene 0,0,0 at there own origin point and exported from there.

There is no modifier that does that, you’d have to create a separate bundle for each object to have all of them exported at the scene 0,0.

Hey mate, the Apply Modiferes now applies them even if not enabled, (both render option enabled or enabled in general).

I’ve made it so it removes the modifiers that are hidden for render, and the rest are applied. Available in the develop branch.

I’ll look into it, thanks a lot