FFMPEG / QT / H.264 render problem in XP

Hi there
I was trying to submit to the latest Animwatch challenge and could not get a render to work in time :frowning:

The format requested was…

  • SIZE: 400x300.
  • (Keep the 4:3 aspect ratio. If your film is widescreen, letterbox it.)
  • VIDEO: Use QT, either Sorenson 3 or H.264
  • AUDIO: Use AAC (either stereo or mono is fine)Using 2.44 FFMPEG and the above setting blender just hung…on my home machine and also the one(s) at college.

Here’s a still.
I used Mancandy and Ludwig


I think the H.264 codec is being accessed via QuickTime’s codec library. You can only use that codec from the QuickTime Professional interface EVEN if you have QT Pro installed on your machine. It’s locked against use by all other applications. It shows up in Adobe After Effects also but it can’t be used there either. It’s Apple’s main selling point for QT Pro 7.

and i think you have to use NTSC PAL or other standard resolution, not 400x300.

EDIT: just did a test, and video was produced, but WMP only played audio, and Quicktime hung. When I did Quicktime H264, Blender hung on the audio codec. And I have QT 7 Pro installed.

I think the work around is in QT Pro to load in the image sequence and use it to render out to H264.

In format select FFMPEG. Then in Video tab, select h264 and in audio tab aac (windows xp, blender 2.44 svn). A just rendered a nice 48 frame animation of The Cube, that plays well in VLC. Video doesn’t show in Windows Media player, but I guess that’s because the codec doesn’t come automatically with the player, but only with third party software, see http://forums.afterdawn.com/thread_view.cfm/214975 . Don’t know why it won’t run in QuickTime, though


I’ve successfully exported H264 video from a tiny little utility called QuickMix (OSX), so it is possible. I don’t have QT_PRO. However, I’ve also had problems with H264 from other exporters.

It’s nice if this thread comes out with a simple workflow for the animclips challenge render.
I used ffmpeg, and instead of render button, hit the viewport render (in the 3d view header) with CTRL pressed. Nice, but I still have no sound…

Have you selected “multiplex audio” in the audio tab for ffmpeg?


I FEEL YOUR PAIN(im not yelling, im crying)… I too could not submit my entry because of the lacking sound clip…If I had only posted this sooner :frowning:

I have quicktime pro, and it still won’t let me use it in adobe after effects or blender, they both just crash. That was the final straw. I now use XviD. It is sooooo much better than Quicktime.

In animation challenges, the quality of the render should not matter. In fact, the old 10secondclub would only accept MPEG1 submissions at a dictated size. So there’s no real need to be looking at high-quality, difficult codecs just to get a submission video. (EDIT: I see these codecs were requested - so ignore that comment.)

I tried the VCD shortcut and got a multiplexed (audio+video) render - and I got this out of Blender 2.44 for OSX which, technically, does not even have ffmpeg working (I noticed it by accident in the list of options).

When you have a deadline though, you should not be relying on new features. Always have a tried and tested backup plan in place - like virtualdub, iMovie, QuickMix, Mpeg2Stream, QTPro, etc…

As for Xvid vs QT - one is a codec, the other is a container so I don’t think it’s a fair comparison. In fact, I’m pretty sure you can have a Quicktime/XVid movie.

It’s also worth noting that ffmpegX, an OSX GUI front-end for the ffmpeg utility, also has barrel loads of trouble delivering a muxed video with almost any combination of codecs and containers - so don’t assume Blender is necessarily at fault here. Also note that, as I understand it, some video codecs will only work with some audio codecs and different codecs and containers have different restrictions (like video having to have dimensions of multiples of 16 pixels etc). So, unless you also know all these restrictions, it’s difficult to just press some buttons and get the desired result.

Maybe people can give us some explicit settings they’ve used successfully from Blender ffmpeg. What did Elephants Dream use, for example?

Hmmm, small but interesting update.

I just tried to render to H.264 from Blender 2.44 using Do Sequence with no ffmpeg settings. Just a straight Quicktime/H.264 sequence render. Blender renders one frame and crashes on frame 2.

HOWEVER, I opened the same file in Blender 2.37a, and it rendered successfully. Which suggests this is not an ffmpeg problem or an A/V codec conflict problem or a licensing problem (?) but something in the way BL2.44 is handling the render (unless 2.37 simply ignores a licence restriction).

Also note that we don’t get access to all of H.264’s options (not sure if this is a system-level thing or Blender controlled).

OS X.3.9
QTPlayer 7.0.1

EDIT: Seems it has been logged as a bug but I see no solution. Interesting that it works fine in 2.37 though.

Thanks dudes…I’m still not sure how I’m going to proceed though :frowning:
AndyD’s suggestion is a good one though…how would other people solve this problem?

If your particular problem is only happening with ffmpeg then your short-term solution is to render out the video and mux it in a separate application. Sorenson 3 should work and, with the right settings (set the bitrate manually rather than using the good, better, best sliders) you’ll usually get a pretty good result.

VirtualDub seems to be the popular choice for post-editing in Windows. You might even be able to render out to an uncompressed format like AVI RAW and use VirtualDub to save in the desired final format.

AAAAAAAAAAAAAHHHHHHHHH!!! (CRAZY JOY SOUND) I Had never noticed there were these two new “video” and “Audio” tabs besides the old “Format” one in the render panels! First time that I miss a long expected new feature in the flow of new things! :rolleyes:
I guess it’s not the last…

If you’re on a windoze machine perhaps you might like to try the On2 VP7 codec. It’s available free for non-commercial use and encodes as fast as MPEG4 with H.264 file sizes. I ran across this yesterday and it appears in Blender’s AVI codecs library upon install.