File association with Blender in Windows 7

Hi All,

I have more than a problem an annoyance with Blender and Windows 7.

Like most users, I regularly update my version of Blender to the latest; I always download the ZIP version, for convenience. In a new installation of Windows, I can right click the .BLEND file and navigate to the location of Blender executable, and when I double-click a blend file, it will open in Blender.

But when I download a new version of Blender and try to make it the default application for BLEND files, it fails to set it and I am forced to open the BLENDs in other less convenient ways (via File>Open in Blender, drag and dropping, &c.); so the file association is gone and the system refuses to associate BLEND files with blender anymore. When I re-install Windows, I can re-establish the file association, but when a new version of Blender comes out (and, alas, this happens quite often!), I loose the file association again.

Has anybody encountered this problem before? and, specially, is there any solution?

Please help

I have encountered this before. Seems to be a Windows bug of some kind. I never solved it. After reinstalling windows one time, I just made a Blender directory and instead of changing the .blend association, I just always unzip Blender to the same folder after cleaning it out.

That’s probably not very helpful if you’ve already got the problem though…

Open a command shell in windows and ‘cd’ to your blender binary, or browse there via your windows explorer, shift+rightclick the directory view and select “open command promt here” from the context menu.

then type ‘blender.exe -r’
That should re-register the .blend in windows and hopefully with the binary you called the parameter with.



Hi, thank you for your response.

It is weird. I followed your instructions and everything appeared to work (see screenshot). But when I try to actually double-click the blend file, it prompts me what program I want to use, so in spite of the evidence nothing appears to have changed.

Any ideas anyone?

Is your user having administrative rights?

@Arexma. The user is administrator (in fact is the user hidden in Windows 7 admin); I hal also tried to run the CMD as administrator within the admin profile, but I got the same results.

Yep, I tried the same things and they didn’t work.

In the past, I’ve had to go into the registry and change the setting that Windows uses to define what invoking “Blender” on a file means. I can’t remember off the top of my head what that setting is/was anymore, but searching for “blender.exe” will probably point you to it.

Hi guys,

I finally managed to resolve the issue; it was a mixture of simple registry tweaking, CMD and some windows explorer.

To resolve this anno

  1. Change the registry manually in the HK_CLASSES_ROOT\Applications\Blender.exe, to actually reflect the path of the correct blender.exe you wish to execute, followed by a %1 (for example “C:\blender-2.70-windows64\blender.exe” “%1”).

  2. <SHIFT> right-click the folder where the “correct” blender.exe lives and open CMD there, then issue the command suggested by Arexma, blender.exe -r

At this stage if I double-clicked the blend file, still windows doesn’t know what to do; it seems the problem is still there, but it isn’t; you need to

  1. <SHIFT> Right-click the blend, and select “Open With”; now Blender executable is in the list; don’t forget to tick the box “Always use this program to open this type of file”, before Okeing the file association box.

I hope this helps; it helped me!

Good luck & happy Windows blending …

Thanks septruiz. It works for me.
Here’s the Registry bit: