Files are not saving

hey there, forum!
I have been learning blender for the past week or so, and haven’t been saving files. Today I finally started saving my work, but after several hours of work and saves, the file I was saving to shows no updates to the original sculpt. It’s just sphere!
I have read and write permissions to the folder on Linux Mint, and have tried this dozens of times in different locations trying to get it to work.
The strange thing is that the file saved initially. I can open it and see that initial save, it just doesn’t save anything to the file as I work.

I am really at a loss here. Any help would be greatly appreciated!!

I use linux mint too, but I’ve never seen this problem! Are you saying that you can create a .blend file, but you can’t otherwrite it with ctrl+S?

1 Like

Yes that’s exactly it! ctrl+S does not work, nor does saving manually from the File menu.
Once the initial file is created, no updates to it are saved and no recovery file can be found in the tmp directory.

I had such a nice face going, too lol

Well, I have no idea what was going on, but I just installed a copy of 2.83 and everything seems to be working fine. I was on 2.82, but I really can’t say if that’s the issue or if it was just some weird install bug.
Anyway, thanks for trying!

Glad to know it worked out. If anything like this happens again, try running Blender in a terminal. That’s a common way of finding clues for this sort of issue

1 Like

I was running in a terminal, and there were a couple of ‘brush not found’ errors that didn’t seem to have any impact on use, but I also noticed that there was no terminal activity when I attempted to save.
I’ll definitely remember that for future reference though. Thanks again!

Actually, I spoke too soon. I just started working off a fresh restart. I tested to make sure that files were saving…and it seems that files are still not saving.
Now this is getting really weird…

What happens when you explicitly try to “Save As” over an existing file? Are there any errors that show up in the terminal?

No, that’s what’s so strange. There are no errors upon save attempts, just…no save.
I tried to fix this so many ways last night before frustration took hold…
I backed up my files and reinstalled Mint and a fresh copy of Blender, and now…everything works fine.
Whatever was going on must have been some goofy Linux glitch (I suspect permissions…but found no evidence that this was the issue), but it works now!

Thanks again for your help