Filmic settings do not work with Blender command line rendering! HELP!


(cekuhnen) #1

I have a very hard time activating Filmic with rendering Blender remotely via a command line:
Any idea how to make this work?

Job Bash:
#!/bin/bash
#PBS -q accq
#PBS -l select=5:ncpus=12:mem=10gb

module load blender-2.78a

blender -b --python cpu.py

Python Script:
import bpy
bpy.ops.wm.open_mainfile(filepath=“render.blend”)
bpy.context.scene.render.engine = ‘CYCLES’
bpy.data.scenes[“Scene”].cycles.device=‘CPU’
bpy.context.scene.render.tile_x = 256
bpy.context.scene.render.tile_y = 256
bpy.context.scene.view_settings.view_transform = ‘Filmic’
bpy.context.scene.view_settings.look = ‘Filmic - Very High Contrast’
bpy.context.scene.render.image_settings.file_format = ‘PNG’
bpy.ops.render.render(write_still=True)
bpy.data.scenes[‘Scene’].render.filepath = './cpu

Error output:
found bundled python: /wsu/apps/pre-compiled/blender/blender-2.78a-linux-glibc211-x86_64/2.78/python
read blend: render.blend
Color management: scene view “Filmic” not found, setting default “Default”.
Color management: scene look “Filmic - Very High Contrast” not found, setting default “None”.
Blender quit


(troy_s) #2

I see your version is set to 2.78a. Filmic wasn’t integrated until 2.79.

On a local machine, setting the OCIO environment variable will work.

If you use the offical Filmic download, you can perform:

export OCIO=/path/to/the/opencolorio/config/file/config.ocio

Note that if you do this, you’d need to change the names of the transforms accordingly.


(cekuhnen) #3

OMG this hurst - am I that blind? Yes Claas. hahaha this is sad and embarrassing …

I fully assumed they just downloaded the latest version …