Filter icon (Scene Collection) is not there (Need help)

I tried reinstalling multiple older versions and newer versions of Blender, but the filter icon at the scene collection is not there. Is this because i need to setup something when i install blender or something else. (Need help, been stuck at this for almost two weeks.)

You could try the portable version… there’s no install needed, just unzip and run. Then you can try going to File > Defaults > Load Factory Settings and see if that works for you.