Finding and fixing small GE bugs in 2.43 for next release

Hi folks,

There is a push on to get as many GE logic brick bugs as possible fixed for the next release ( which could be 2.50! ).

Like before ( which was extremely useful ), can you…
a) locate and isolate the bug
b) make a small .blend file illustrating the bug
c) describe the bug, and also ( just as important ) describe what should happen if the bug was fixed.

Just describing the bug without an associated ( and simple to use ) .blend file makes it more difficult to track down the bug.

Here’s one from an earlier set of postings, which relates to the TrackTo logic block.

PlantPerson wrote…

> I also made a test file for the track to bug, which is not fixed:
> www.gorilla3d.com/plantperson/trackto_bug.blend
> Thanks again!

Here’s the Windows .EXE…
http://www.candointeractive.com/blender/blender.zip

( if pthreadVSE2.dll is missing for you, download it here… http://www.candointeractive.com/blender/pthreadVSE2.dll )

and here are the patch files to apply it to your own build…
http://www.candointeractive.com/blender/KX_TrackToActuator.cpp.patch
http://www.candointeractive.com/blender/KX_TrackToActuator.h.patch

Regards…
Mal

Added objects aren’t registering the Ghost setting.

http://christopherschons.com/temp/blender/addObjectBug.blend

This blend has 2 bullets with the exact same settings: Actor, Ghost, Dynamic.
The added object (bullet2) collides with the plane, while the object on the original layer (bullet) passes through.

Also, can’t wait to get that parenting bug fixed. Keep up the good work.

OK, I’ve just fixed the TrackTo to work even with the camera pre-rotated, and have updated the links on the first post. PlantPerson, can you check if it works OK for you?

I’m currently in the middle of trying to get the joystick stuff working better - can a few people post example .blend files of how they currently use the joystick sensor?

Next up is to have a look at the ghost bug ( for skullbunny above ).
Mal

mal:
I noticed that you (or erwin or charlie) fixed that realtime text color bug with Blender Materials. However, it seems that the text is still not previewing in textured mode like it used to. In 2.42a a bitmap text object would display the value of its “Text” property in textured draw mode. Now in 2.43 it only shows the “@” symbol until you press the “P” button. Could that be changed back? It’s helpful to me to be able to see the text while I’m editing the game.

  1. Here’s a tracking problem I ran into involving a tracking object parented to another tracking object.
    http://christopherschons.com/temp/blender/TankTrackTest.blend

The red tank moves forward and has a child that tracks to the player and adds a homing shot. Works fine.
The blue tank slowly tracks to player, and has a child that also tracks to player, but just spins around wildly.

  1. Another tracking oddity. (ignore the WASD movement. I haven’t updated it for 2.43)
    http://christopherschons.com/temp/blender/robotronic.blend

The character tracks to 4 objects, (north south east west) depending on which arrow key is pressed. It works for every direction except southeast(down+right), which ends up pointing left. I’m hoping to replace it with python at some point, but thought I’d mention it anyway.

  1. For some reason when i add a constraint actuator, it resets after i set it, then works fine the next time i set it. Weird. I run OSX, if it matters.

Hi there skullbunny,

Excellent demos btw - they could be turned into very cool games, now that the parented trackTo works!

Some good news - I tried your 1) and 2) demos, and they seem to work great with the patch!
( I was able to see the problems by using the official 2.43 release )

Can you get those patches applied to your build, so that you can test on OS/X?

I’ll submit the patches now to Erwin, it seems to fix the problem.

Regards…
Mal

NOTE - In 2), to shoot diagonally you are doing two separate trackTo blocks and hoping that they will average their results. Unfortunately the trackTo blocks work independantly, and in the order processed, which is why you were getting problems.

You might be better to have 8 potential directions, and set up a slightly more complex logic block sequence to point to all of them.

When I try to start it, it asks for a “pthreadVSE2.dll” which I don’t seem to have…

malCanDo - when you submit them to erwin also put them in the patch tracker please. Also snailrose can review GE patches also…

LetterRip

There’s a bug with getOrientation and setOrientation with objects that have been parented.

http://www.tutorialsforblender3d.com/blendFiles/OrientationBug.blend

You might have fixed it when you fixed the Track To problem with parented objects. There’s also the bug with getPosition and setPosition with parented objects. I’m guessing that it’s the same bug for all three.

I downloaded your Window.EXE but it asks for “pthreadVSE2.dll” which I don’t have. Optimized version of Blender maybe?

Hi folks,

The pthreadVSE2.dll can be downloaded here…
http://www.candointeractive.com/blender/pthreadVSE2.dll

If you get it working with some of your .blend files using parented objects and trackTo, let me know so that I can ask for a commit to main source.

Letterrip wrote…
>when you submit them to erwin also put them in the patch tracker please. Also snailrose can review GE patches also…

I posted it to the patch tracker a few days ago, hopefully it’ll be reviewed and committed if a few people on the forum here confirm it works OK.

Mal

I don’t have a blend, but added-objects property’s aren’t registering with the collision sensor. I have an added-object bullet with prop:dmg. I have a cube that is supposed to end if it collides with prop:dmg, but it doesn’t work. It works fine if an object on the original layer with prop:dmg hits it.

I can’t get text to work at all in games. All I get is this symbol (@) displayed where each character is supposed to be, with or without Blender materials, in the Blender display and in the actual game (.exe file).

Hello…God ?!
It works for me, in Linux OS.
Check the property name “Text”
And don’t forget to pack the file
Bye

Anyone knows if the patch that malCanDo did in fixing the track to actuator on parented objects is going in the next blender patch…that is a great fix :wink:

i continued works in bots system but i dont understand this menssage in the console
one talks about an error in the collision sensor when this it is off ???

warning btcollisionDispatcher::needsCollision:static-static Collision!!

the files:(works fine in blender 2.42a but dont works correctly in 2.43)

http://pochoblender.googlepages.com/DETECTOR-rayPLAYER.blend
or
http://files.filefront.com/FPS_BOTSPATHv1zip/;6745810;;/fileinfo.html

or another file with the same problem:
http://files.filefront.com/IANODOS3blend/;6482342;;/fileinfo.html

thanks for any aid

pthreadVSE2.dll,

I think that is part of Verse…

as far as ghost not working, Are you guys porting stuff from 2.42a?

if so just do this (on a copy,not your original file) …
untick the ghost and save…
select the mesh and press F then A untill all faces are selected… then W and on the menu select, clear doubleside…W then clear light… W then clear alpha… W then set collision.
save it again.

close blender, then re-open/load your game file…
now re-tick ghost…
if that dose not work select the mesh again , press F and press W then press CLR collision.
I was able to make Zody, Br!x, and zodyblast all work properly using the above method.

added object instances not registering collisions with collision sensor after more than one instance of the object is added in…

when you press space you add in a yellow,red, or blue cube… when one of these cubes hits the ground… it should add in purple cube… it does this once for the first time a yellow,red or blue cube is added… but stops if you add in more yellow,red or blue cubes

a link to the file…
http://www.savefile.com/files/565519

This is not a “bug,” per se, but I’d really like to see a feature which would allow a face to be collision-sensitive but not block the mouseover sensor.

At the moment, the mouseover sensor ignores all faces which are not collision sensitive, but collision sensitive faces are always detected by it, causing them to sometimes block mouseover interaction with other faces. Sometimes this can be fixed by turning the offending face collision-insensitive, but occasionally I need to keep the collision sensitivity. Such is the case with my character’s invisible collision box: it sometimes blocks mouseover interaction, but for obvious reasons, collision must be enabled on its faces.