Finding and fixing small GE bugs

Any time I try to blend two actions (a walk cycle and rest position), it works in the GE, but when I esc out, Blender crashes. Here is a link to the thread I started on it yesterday.

Primarily the fixes I’d like to focus on would be to do with the Sensors/Actuators/Controllers - eg the Radar sensor isn’t working when i do X, the motion actuator doesn’t seem to work correctly when i do Y etc.

Also, with regard describing the error, a .blend file really does make my task a lot easier - if it only takes a minute for you to build and upload a .blend file with the exact problem, it might take me 20 minutes and I might miss the problem.


Good morning Mal,
Here is my blend file packed, compressed, and zipped:
My problem is stated in my previous thread:
Thanks for the help,


just a quick question… I understand the point of a blend file… but some bugs are sporadic and a blend file doesn’t really help to illustrate some of these types of bugs… of course I can make one detailing the problem with a text file etc etc. but the bug might not appear when you run the blend file, for example the unloading of texture maps etc. anyway must we still send you a blend even if this is the case?

Anyhow I really appreciate you fixing stuff for everyone… thanks!

In the case where the bug is sporadic, it might take me a while finding it, even with a good .blend file - I’ll definitely look into some of these over the coming weeks and months, but if there are sensor/controller/actuator bugs that occur consistently, these are the ones that I would have time to fix, and that a .blend file would be excellent to help illustrate the issue to me straight away.

This is something that bothers me for awhile
The propertySensor set at Changed Mode seems to be firing twice.

Check blendfile

please have a look on
I have put a link on a .blend file which can help the debug on the Message and Propery sensor which fire two positive pulses.

OK, I FINALLY got some time to spend on Blender coding / fixing, so I’ve uploaded a new version that seems to fix the above two Sensor related bugs ( Message and Property firing two positive pulses - the message one was fixed with an earlier patch - , as well as Changing Mode seems to be firing twice ).

You can download the fixed Windows .EXE here…

For non-windows guys, the patch files ( for both property sensor and message actuator ) are here…

Let me know if it works OK for you, especially in more complicated GE .blend files.

Hopefully we can get these fixes into the next update to Blender ( due out before Christmas I think ).


Hi Mal,
I checked out your Windows build to see if it would make any difference with my previous problems, and it did not. I also have a new potential bug, with constraints:
In addition, I tried out your build with one of my characters, and when he jumps, (a force is applied for the motion while an animation plays), the character doesn’t come back down! It works ok on 2.42a.
Have a nice day,

I noticed that the Property Sensor will not evaluate a Property in the Value field. It will only evaluate a number. It would be nice if that were fixed.

Actions (with constraints) don’t play as expected since a couple of versions:

  • they crash blender when quitting the game (inside blender)
  • play wierdly in the exe file: IK bones don’t follow the rules applied to them. (but IK bones work well inside blender , pressing “P”)

This is the link to the thread (and the blend file)

Thanks a lot,

Ok, by now I’m sure everyone is sick of hearing me rant about this, but:
TrackTo bug
Track to does not work correctly when its object is parented to a rotating object. Bug tracker entry provides all the links and info you should need, including a .blend:

And another one I hate like crazy:
Message sensors cannot trigger IPO actuator
Pretty much speaks for itself. A message sensor cannot be used to trigger the IPO actuator. This bug appeared only in more recent versions (I believe it still worked last in 2.36) but it’s been around far too long in my opinion. Please fix this!

Thanks a lot malCanDo… you’re doing a great service! (Don’t forget to check the bug tracker… it’s full of unfixed problems)

Ok malCanDo its cool if you post an exe of your new build here. but what you really need to be doing is submitting a patch so that your fixes may be considered to be committed to the CVS.

DO NOT COMMIT! Unless you are told that you can. Even if your patch clears you probably wont be the one doing the commit. Just submit a patch, if you dont know how to make one I belive there are instructions on the blenderwiki.

what about parent to bone not working?

and umm… ya press space and the cube shou;ld mode with the tube/armature

i know this thread is kinda old but it’s still usefull if he’s still doing it

EDIT:ya and when you replace a mesh it dont use the new meshes collision. like if you replace a mesh you can only use collisions from the old mesh not the new one

That’s not a bug. It’s a feature that got removed because of the armature rewrite and hasn’t gotten figured out and put back in yet.

ya thats what i said. but someone said i should post it here

Hello malCanDo,
I have tested your version posted on the 22.11.06, I saw your change : you remove the second pulse, this does not sort the situation where the event is fugitive and need to be cancel immediately on the next frame.
To help you, I have made up a .blend which show in easy way the effective pulse. For more detail, please read the Read me text buffer :
Thank you for your work

Keleido, can you check this new build, to see if it works OK for you for the fugitive events.

The negative events seem to work OK according to your first set of results, except for the message sensor - this might be because the message now only fires once.


malCanDo, any chance of fixing my bugs? (above)
hate to be a nuisance, but I’m very eager to see them fixed!

Hi PlantPerson,

I’ve been looking briefly into the TrackTo actuator, to see if I can make it work if the object is parented, but I wanted to get the basic messaging stuff fixed asap.

For the IPO / Message one, can you knock me up a very simple test ( eg just with a message being fired on keypress, and with a monkey head turning with an IPO ) so that I don’t spend half of the time trying to recreate the problem - also, put in some text that explains what is happening ( or not happening ), and what should ideally be happening if I fix the bug.