Fire with Transparent background problem

First of all, I need to say that I’ve never really used the Compositor yet in Blender, so I’m very new to this. I do understand how nodes work from working with Materials.

My first problem was that the fire did not show in the final render the way it does in the real time viewer. I would have preferred no background at all so that I can put some images together later in photoshop, including realistic fire that you can partially see through. Is there a way to do this? When I open the PNG in photoshop and apply a background, the fire still doesn’t show up. I started looking into this and only found a few older explanations that involved using an Alpha Over node in the compositor. So I started playing around with that, eventually I just used a mix node and got the fire looking the way I want, (though now it had a black background, not exactly what I wanted). I thought I would make do and started looking around on how to save the new composited image. Do I just use F3 again?

Anyway, in the searching for a way to save, I inadvertently unchecked the Background box, so that the image no longer was in the background of the compositor. When I turned it back on all my images, including the ones in the nodes, disappeared. I had saved just previous to this, so I quit and reopened the file, and they are still gone. I couldn’t figure out how to find the Render result I had been working with, that seemed to be gone too. I started using the saved PNG file in the compositor instead, but now, as you can see in the second image, the fire is doing very odd things. Yes, there are several questions here, so I will reiterate them:

  1. How can I make the fire show up against the transparent background and still have a transparent background?

  2. How do I find my Render Layer Result that I had after rendering for 8 hours? Why did it go away when I unchecked background?

  3. If I’m to just use the previously saved PNG image, how do I fix the new problem with the fire looking crazy?

  4. Do I have to re-render the entire scene all over again to get a new Render Result to work with?

  5. Lastly, how do I save the new composited image if I get it the way I want again?

The first image should be of the final render result which I saved as PNG, with no fire showing in the transparent areas. the second is of the node set up after I had lost the render result image I was working with, and instead had to use the PNG file. You can see how odd the fire looks. Again, If I could get rid of the black background as well, but still see the fire, I would be very happy.

Thanks for any help you can offer. And if possible be very clear about any node set up advice and settings so I can try it out and understand it. None of the tutorials on fire out there mention this issue.

i’m not entirely sure what happened, but i can give you a few guidelines:
a. unless you are using an addon or the output node, make sure to save your render result (via the image editor). if you have render passes, use exr multilayer format (which is not the same as regular exr format), otherwise, the passes will not be saved.

also, to save the alpha information, you need to plug the alpha into the alpha socket in the viewer/composite node, otherwise you will lose the alpha information (and i think that’s what happened here). there is a reason these sockets exist!

to make sure you use a correct workflow, i suggest doing a quick test render and saving it to disk.

Sometimes you have to get very particular to produce the effects that you want. The MultiLayer OpenEXR file format is quite essential for this purpose, because it captures in a single file the many “layers” of digital information that you need, with no “loss.” This format was expressly designed for use as a “digital intermediate” file.

In this case, for instance, Z-depth (the distance of an object from the camera) might be one way to properly separate the fire from the actor. Another way might be the “layer-numbers” (as in: “the thirty-two buttons …”) associated with parts of the actor model, such as “the fingertips.”

Another key thing to remember about compositing is that, in any scene, there are both “actual lights” and “practical lights.” Where (and what …) the light-source actually is, and, separately, where (and what) it would be, if the scene were actually real. For instance, “the fire” probably would not be an actual source-of-light. But there would be a plausible source of light to accompany the fire, and-d-d-d you probably want to use a separate render-pass (or, a completely separate render) which incorporates only that light, so that when you “mix-down” the completed image, you can adjust both the levels of the fire and the levels of the light which the fire appears to cast. You might even separate “the light that the fire appears to cast upon the actor” from the light that the same fire appears to cast upon other things.

I used the analogy of “mix-down” purposely. When you walk into a recording studio while they’re recording, it’s a boring place: there might be only one musician there, banging on a drum (say…), while listening to a click-track. Or, a saxophonist, also in a room by himself. The song, itself, is “made” in post-production, and sometimes every one of the channels on that big, wide board are in use at the same time.

(And, by the way: that is a terrific male model, a very dramatic pose, and lighting. Well done.) :yes:

Thank you for the help. I see I still have a lot to learn about compositing. Also thank you for the compliment. This is a character for a book i’m writing, so it’s been a lot of fun creating him visually. Eventually I hope to use this for the cover.
Anyway, I was going to start over with a new render today, but now I have another question:

I had saved my blender file in the state as you see it above in the pics, before quitting. I opened it today, and everything is gone, though in the image input nodes, the name of the file is still there. This is similar to what happened yesterday when I had toggled the backdrop view off and on. Could this be a bug?

I’m starting over anyway at this point, but I still need to understand what’s happening before I can proceed. I also don’t seem to get the composited image in the UV image editor window even when it’s plugged into the viewer node. Is there something else I need to do to get it to show up in that window? Obviously I need it there so I can save the final image. Am I missing something or is this not working the way it should? I included a pic to illustrate what I’m talking about, but it doesn’t show that the backdrop is checked, though it is.

well, what you are describing is the way things work for me also. apparently when you opne the file you need to check and uncheck the background image (or unplug and replug the node tree to the composite. i think that also works) for the compositor to recalculate, or something. idk exactly why that is, to be honest.

Maybe what I really need explained is why I get this in the Preview Render in the viewport.

But when I do a final Render, I get this…

I’ve also noticed that there is no alpha created, though it is using the combined alpha and color channel picked. If I look at just the alpha there is nothing there. Iv’e plugged this into the alpha socket, added alpha nodes, mix nodes, tried several things. Nothing recreates the image that is in the rendered viewport. If Cycles is supposed to be able to do smoke and fire now, why is there such a big difference from the preview render to the actual render?

i played a little with fire on my (slow) machine, and indeed, there is obviously alpha tranparency involved in the fire. i assume that’s beacuse of the volumetric components of the fire material. it would seem that this transparency is not reproduced in the viewport. if you are using transparent background for rendering, here is one way you can get the results you want:
first of all, the fire on transparent background:

now, the fire “enhanced”:

and just for reference, this is the alpha of the fire:

1 Like

Oh cool! I never tried the greater than node. I’m going to try that! I really hope this works. I did figure out a workaround using screen mode in Photoshop, but it’s lets than ideal.

Thank you for all your help. I played around some more, and even with your exact node set up I was still ending up with the same results. I thought of a way that might fix it, though it doesn’t answer the transparent issue. Since I plan on using a background of some kind in Photoshop maybe I could actually apply the background in blender. If the fire needs something behind it to render correctly then I should just put something there. I wondered tho if my material settings weren’t bright enough, the emission strength I kept a bit low. I didn’t want them too bright, then the colors of the fire would disappear… Thanks again for playing with it to give it a try. I also have a slower machine.

you’re welcome :cool:
well, if it’s still an issue, you can include a blend file. that way we can see what’s going on. (now i’m intrigued…)

I might do that. Right now I have something I’m happy with. I’m afraid to touch anything in the file because it’s still rendering and I don’t want anything to blow up. As you can see it works fine with the image plane place behind the model, then the fire renders perfectly. Yikes, it still estimates another 16 hours… its been going since yesterday. (I did up the resolution though, so I can’t complain) Just a slow machine. One of these days I need to figure out how to set up a render farm.

Isn’t the first image your second image a premultiplied version of the flame? Just use the node Converter > Alpha Convert. Use it inline with the image before alpha over and switch the function.

I am still unable to do so, would you mind showing me the setup?

Nope, false alarm. I didn’t succeed in it. I am erasing my comment now.