first blender project: my vacuum system

Okay here it goes, my first renders. I’m happy with the result so far but there are a few things I haven’t figured out yet:

  1. get the cilinders round. I played with the set smooth and subsurf options but didn’t get it to work. The whole surface breaks up when I do that (and I did try the normals to outside thing). I modelled the system in BRL-CAD (awesome open-source 3D CAD program by the way) and imported it into Blender as dxf.

  2. for the green laser beams, when I join the 4 cylinders it does not look as a single surface. Can anyone tell me how to fix it?

  3. I made an animation of this (1.7 Mb), but the transition from this to a 2D animation is bad (non-existent). Any ideas on how to fix this?

I made the background white on purpose so that this can be included in a presentation.

get the cilinders round

.dxf has a tendency to import each face individually. Select all verts in Edit Mode and W-5 (remove doubles).

for the green laser beams

I keep this as one of my stock of homemade primitives (on layer 20):


Thanks a lot Fligh! That 3-way looks great. I will try to make a 4-way just like that. What I did before was to make 4 cylinders and join them. Guess it’s better to work with 1 object and start extruding?

The .dxf had no double vertices, guess my best option is to re-import it with more vertices to begin with to make it look smooth.

The .dxf had no double vertices

Are the faces loose? If so you can increase the limit on the distance between verts when removing doubles (F9, edit mode, Mesh tab and to the right of “Rem Doubles”)

If you can’t get it smoothed out please send me the .dxf file, I’d love to tinker with it:

([email protected])


No the faces aren’t loose. For some reason the subsurf function works all of a sudden, but it smoothes everything, including the 90 deg angles. I think the autosmooth should be for smooting just faces with larger angles, but it only goes up to 80 deg and does not seem to do anything. I’ll send you the dxf in a minute.

Thanks again, trying these things makes me learn a bit quicker.

There are loads of doubles (.dxf always has). Select one part, tab into edit mode and hit A to select All (yellow) then hit W-5.

Unfortunately, you’ll be able to smooth but, since all the faces are triangulated, the result won’t be what you want. However, with Blender’s modeling tools it’s easy to model these without the triangulation and get very descent results.