First IK Rigging Issue

I have been trying to rig this bear and I am having trouble with the IK on the foot.

I have been following this tutorial on Youtube About approx at 7:10 he starts to talk about the ik bone being attached to the foot bone.

So I am in pose mode. I select the foot bone then shift select the ik bone then ctrl p and keep the offset
then I do ctrl shift c and add the inverse kinetic then over at the properties panel I begin to select the bones that
are appropriate in the drop down menus.

I tried several times and It isn’t working. So I would like to know what I am doing wrong.

Hee is the blend file

Would there be a better tutorial on how to do a basic rig with IK and chain length for a cartoon style character.

i used the smae tutorial lol

from the file you sent everything is really close but you didnt add the extra part for the knee like you did the elbow, so you need to add that floating bone for the knee and then change the pole target to that bone which will be “knee bone.L”
if you go to about 3:50 in the vid youll see it

Quickest way is to just select the foot bone in pose mode and press ‘shift I’
(edit) and here is the documentation from the manual

Modron thanks for the response but when I do Shift I it has two options I have tried both and neither are working.

It goes bunkers when I hit g to move the bone. What am I doing wrong.

Target Armature 001
Bone Foot IK
Pole Target Armature 001
Bone Foot 01.L

and I just noticed the lower leg is acting like the IK so how do I delete tthe IK from the lower leg without deleting the bone.

First thing I do when debugging rigs, go to pose mode, select all bones, altR and altG to remove transforms. Do it again, and if bones jump around as they do here it’s not a good sign. It means IK probs, and the problem here is the pole target has been designated as the foot. Except the foot is the child of the bone with the IK constraint on it, therefore it controls the bone that controls it… this is called a cyclic dependency and it causes that flickering because Blender can’t resolve the final location for that bone.

The solution is to have pole targets that are completely independent of any bone in the chain. Usually they ar parented to a ROOT bone, but the tutorial you were foliowing (didn’t watch it all, sorry) might not have a root. In any case what you need to do is ADD two more bones to your rig if you want pole targets. I did that in the file I’m reposting but you should do it yourself just for practice…

  1. Delete the pole target field in the IK. Do this first, so Blender does not crash, although Blender handles these errors with a great deal of grace.

  2. make a new bone in the same armature, and position it. Make sure it’s not childed to any other bone.

  3. Designate this as the new pole target.

  4. Do one for the elbow too.

I did note that the video parented the foot bone to the IK target, this means that you have to be careful how you drag the ik target because the foot will stretch the mesh as it stays with. Not sure how he’s going to go on and fix that, but I prefer to do it the way I have in the attached file.

He also parented the arms to the hip which seems awkward, and I changed that too, and although your Bear seems rather too limber in the belly, as in too many bones, that’s just a minor thing - gymnastic bear maybe?

DruBan Thanks

I found out by someone that I needed a pole target for the knee and so I added that and I also cleared the transformations and I also didn’t do the elbow like I thought I also fixed that one. Now that rig is fixed.
I just looked at the file and looks so much better than what I had thank you so very much for that.


I have been trying to get the armature to connect to the bear.
I applied the mirror modifyer to the bear
In object mode I selected the bear then rig did the ctrl p and set the parent with automatic weights
The right arm of the bear has deformed

Thanks for taking a look

Right arm IK pole angle set error. Should be 180. File.

Thanks DruBan Question where did you get the axis for each bone. I can’t seem to find them.

Another issue is trying to join the eyes and ear to the bear. I have done the subsurf for the eyes and when select the eyes to bear I do ctrl j and the eyes move back and the subsurf is gone.

Armature properties - should be a checkbox for axes display.
Should have joined the eyes and ears to the bear BEFORE the armature - now things will need to be rebound. The subsurf on the eyes is on the OBJECT, so when it becomes part of another objct it will be replaced by the subsurf on the bear. You can apply it in the modifier panel before the join.