Fix shading issues on low poly model

Can’t seem to figure out how to fully fix this shading issue I’m having.

You can see on one of the pieces most of the weird shading is gone. Thats because I tried the autosmooth option, but it doesn’t get rid of all of it there is still a little bit of it. Does anyone know what other options I have?

Here is the topo of the piece with autosmooth on it.

add sharp edges to that model, also you can turn on auto smooth at 45 degrees.