Fix the red aura of my lightsaber


(RobertoChiaiese) #1

Hi guys, I modelled and rendered a lightsaber. Next pass is the compositing stage.
I followed the tutorial of CG Geekon Youtube for the compositing of the rendering. I don’t know why there is an “aura” among the end of my lightsaber as you can see by the image below.


The image of the node editor is


I set the material’s IDMask of the laster to 1 whereas the lightsaber’s to 2.
I noticed that if I decrease the “value” of the “Multiply” node, placed between ID Mask and Dilate/Erade ones, the aura gets smaller and the problem is fixed but the blur decrease as well.
Help me, please.


(Mandalorian) #2

In the color management section in the scene tab, change the “View” dropdown from “Default” to “Filmic”.


This will give you a better base image response to work from for compositing.


(RobertoChiaiese) #3


I edited some values and I set the setting that you suggested. It seems that It got better, but on the edge of the lightsaber there is a weird result.



(Mandalorian) #4

I tried replicating your file to see how everything works, and I think a large part comes from how you’re creating the glow. You’re blurring the whole image instead of just the blade to get the glow. Then you add it back over the original with the blurred ID mask.

IMO a better way is to use the mask to drive the glow, so the blade is the only part glowing, not the whole image. The image below shows a basic setup to accomplish this. The ID mask is used to multiply the image, leaving only the blade. This is blurred to take the hard edge off the blade, then the glare node set to fog glow generates the glow. This is then added on top of the original image.


Hope this helps.


(RobertoChiaiese) #5

Thank you for your being so available to help me.
However, I set your values and Obviously It didn’t work so I tweaked them a bit and the result was better but, as you can notice from the image below, the blur of the blame is not like yours.
If I increase some values the light of the blade gets fuzzier but as before the blur is on the top of the lightsaber.


If you want to try directly on my model, here it is the link to download it


Thank you again for your help. :smiley: :slight_smile:


(Mandalorian) #6

Sure thing. :smiley:

I downloaded your file, and here are a couple of the changes I made that made the glow work correctly:


From left to right, here’s how it goes:

  1. You should be using the image itself for the glow, not the AO pass. Since the blade is emissive, it shouldn’t have shadows. Fading glow towards the edges can be done in different ways, and the rest of the chain needs the linear values of the blade to generate a proper glow.

  2. The multiply node should not be clamping values. The scene linear values will be needed later for the proper glow, and clamping gets rid of those values.

  3. You can still use relative for the blur if you like, but I was using non-relative, so if you’re copying you’ll need this. Otherwise, the value should just be small, since the only purpose of this blur is to soften the edge a bit.

To do all of this correctly though a reference for what you’re going for would be helpful. Right now, it’s mostly a shot in the dark since you haven’t clearly indicated what you want as a result. If you want a more realistic look, this is a good direction to go. If you want more of an EP III look, that will require a different approach. Hopefully some of this will help you learn the tools so you can achieve anything you want.


(RobertoChiaiese) #7

Hi, Thank you again for your help and for being so available. I followed your steps and the result of compositing process didn’t change so much.





Is it possible that any settings screw all up?

Attachments