Fix visible edges behind corners in edit mode

Hi everyone,

I have an issue with the way edges are drawn in the viewport.
If I zoom in closely to a corner, I can see the edges behind. See the image below:

Anyone knows how to solve this? I remember that a couple of years ago I had found an answer online but now I can’t find that post anymore.

Thanks in advance for the answers.

it is related to the clipping settings of the viewport. adjust them and they should go away.

Thanks @ManuelGrad for the answer but it did not solve my issue. The clipping works only in perspective mode while in the screenshot I was in orto.