Fixing a distorted area in the mesh with limited geometry?

I need help with fixing a problem with a distorted area of my model’s mesh that I just can’t seem to fix on my own.

The problem is that there is a visibly distorted area on the lower belly area of my model, shown here:

Which is supposed to be perfectly smooth & rounded, as demonstrated in these screenshots of an older version of my model:

I tried to smooth out the area using Sculpting tools but with the limited amount of geometry I’m working with, I could only reduce the distorted area by a limited amount.

I then thought that if I applied the Subdivision Division modifier to my mesh, I could increase the amount of vertices available to me to properly smooth out of the problem area via the Sculpting Tools. While it did seemingly work, as shown here:

Unfortunately, applying the Subdivison Modifier ended up wreaking in other areas, and after asking about the issue here on this site and on another one, I learned that applying the Subdivision Modifier is apparently a bad idea and so my solution to the mesh problem was no good.

I was then recommended to use the Multiresolution Modifier instead as a potential fix, but I’ve also run into a problem with its use. The problem is that I try to subdivide the surface via the Multiresolution Modifier, the model goes from looking like this…

…to this.

Is there something I’m doing wrong? I am using the Multiresolution Modifier incorrectly, or is there something else wrong that is preventing the modifier from working correctly?

I just don’t know what to do :confused:, as everything I’ve tried so far hasn’t worked and I don’t know what else I can do, so any help with this matter would be greatly appreciated.

Thanks in advance!

Blend File Download:
rigging_help.blend (603.4 KB)

I just added another vertical loop getting rid of the ngon that you had in the belly region and it seemed to smooth things out a bit more. Also had to smooth the head out as well after this. Is this what you were looking for? I think in this case your mesh is too low res in some areas, and needs help in the poly flow as well. There are some other potential problems as well that I can see coming up for you, but they can be fixed by adjusting the flow and adding things here and there, however in one of your examples, the ngon doesn’t exist so…

rigging_help2.blend (608.5 KB)

1 Like

Thanks for noticing the ngon, I completely failed to notice it, as well as a number of other ones I found as well :sweat:.

I made further modifications to your revised version of my model by completing the new edge loop you added, as well as fixing the other present ngons & making a couple of other minor adjustments. I do believe that all the ngons have now been fixed, since I did a search using the Select Faces with Sides option to try & locate any other ngons I might have missed and nothing else came up.

The only problem now, unfortunately, is that adding the vertical extra loop cut to fix the ngon problem causing the distortion in the mesh has now resulted in my model losing some of its smooth, even, roundness.





If I use the Smooth Vertex tool on the entirety of the model, it smooths out the newly added edge loops & gives the model the desired clean, rounded look. The downside however, is that causes the model to lose a bit of its original shape.

Is there a better way that I can clean up the edge loops or I am stuck having to use Smooth Vertex tool and manually readjusting the mesh until it resembles its original form?

You should have an addon called loop tools, in which you can use relax and space on a selection of verts that need those, there are some settings you can play with there as well. When I did the first edits, I smoothed some places by selecting only the area needing smoothed and then ran the smooth command, that way the adjustments stay local and not over the entire model.