Fixing the physics

I know how to put a physics now. But the problem is the boxes I made are pushing me away! how do I fix it?

.blend file?

http://www.savefile.com/files/1784644 here is the link

Hello
I’m not sure If I understood your problem, but try to disable “collision” for all the
faces of your character?!
Bye

How do I disable the collision?

Select all the faces in Edit mode. Press ctrl-f. Hit “Face Mode Clear.” Press “Collision,” “OK.” (You might need to unwrap the object first, if it doesn’t already have a UV layer.)