Flashing Lights?


(jsamonas) #1

Hello,

I’m trying to model an aircraft and I’m trying to get flashing lights on the wingtips. I’ve colored the lights green and red like a plane, but I can’t seem to figure out how to make them “flash” brightly.

Any ideas/suggestions?


(Falgor) #2

Well, if you want to animate them, just go to the lamp’s properties in F5 buttons after selecting the lamp, and then animate the lamps energy.

Adjust the lamp energy in the F5 window and press “i” (in the same window) to make a keyframe in frame A, then go to frame B (not too far, otherwise it just looks like a “fade in”-lamp) and adjust the lamp energy and press “i” to make another keyframe. Now you should have a blinking light.


(jsamonas) #3

I’ve got a UVsphere as the light on the ends of the wingtip and that’s what I’m trying to make flash in the animation. So I should add a lamp right in front of the UVsphere? Won’t that color the side of my plane that color?


(EyebrowZing) #4

Generaly lights tend to do that.

I still have very little idea what I’m doing blenderwise but couldn’t you just place the light inside the sphere and make the shpere semi-transparent. I believe you might be able to set the sphere to block the light allowing it to shine through at normal intensity. Maybe even give the sphere a slight halo to give it the effect of a glowing lightbulb.

Again I will say it, I have no clue what I’m talking about here and I’m having my own light issues. So if someone whant to backup any truth I got in there that would be great.


(zachboy82) #5

if you set the light to illuminate only the stuff in its own layer, you can set the plane to one layer and the sphere and light to another layer. There is a button in the lighting properties that is grouped with “no specular” and “no diffuse”. The button is “layer”. In order for this to work though, the sphere and the light must be on the same layer and the plane itself on a different layer. I would think that you want the plane to light up as the plane lights do seeing as how the same thing happens in real life…


(AndyD) #6

You may find that setting a material to “Emit” will achieve the result you’re after. It works well but doesn’t cast shadows or illuminate the area around it - but for small flashing lights that’s probably not important.

Make a mesh for the light fitting, give it a material (red/green) then go to the IPO window. Choose “material” from the drop-down menu and find the Emit value, set a curve and manipulate to deliver the desired effect.

I used this method on this demo animation for the Crosswalk project. All the actual lights are just materials emitting with IPOs for flashing effects. The cast lights (headlight beams and illumination on the walls from top flashing lights) are done with spotlights (halo setting gives a nice “beam” effect).

900K Quicktime:
http://members.westnet.com.au/andydolphin/blender/sweeper3.mov