Flexi Bezier Tool

Just saw this. Not sure if flexi has same thing?

The tweet is actually about Flexi Tool :slight_smile:


Hi, this addon is a must have to work with curves!

I have a problem though, in a blend project I’m doing are several curve objects and when using the addon this error appears when confirming the curve:

Traceback (most recent call last):
  File "C:\Users\srloi\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\blenderbezierutils.py", line 5308, in modal
    return self.subModal(context, event, evtCons)
  File "C:\Users\srloi\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\blenderbezierutils.py", line 6210, in subModal
    return self.baseSubModal(context, event, snapProc)
  File "C:\Users\srloi\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\blenderbezierutils.py", line 6086, in baseSubModal
    return self.drawObj.procDrawEvent(context, event, snapProc)
  File "C:\Users\srloi\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\blenderbezierutils.py", line 5861, in procDrawEvent
    self.parent.confirm(context, event)
  File "C:\Users\srloi\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\blenderbezierutils.py", line 6071, in confirm
    self.save(context, event, autoclose, location)
  File "C:\Users\srloi\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\blenderbezierutils.py", line 6387, in save
    curvePts[-1][1]]) for x in y]
  File "C:\Users\srloi\AppData\Roaming\Blender Foundation\Blender\2.82\scripts\addons\blenderbezierutils.py", line 6369, in getSnapObjs
    p = s.bezier_points[0]
IndexError: bpy_prop_collection[index]: index 0 out of range, size 0

location: <unknown location>:-1

If I delete some especific curves, the addon works fine in the same file, I couldn’t find any difference between the curves that make the addon crash and the ones that don’t.

1 Like

This condition is taken care of now. Please download the latest version and let me know if you still face the issue.

[The problem is actually related to curves having splines with no Bezier points; such curves are invalid. So the error can be gotten rid of by cleaning up the blend file (I guess there is an add-on or option for this). However, this error is reported many times now, so I have considered the condition in the code and filtered the invalid curves.]

1 Like

Cool! I’m gonna try it right now

With Industry Compatible Keymap the Rotation is on Alt LMB. This still works fine in Flexi Edit but not in Flexi Draw. The viewport rotation gizmo is also not working when Flexi Draw is used. Could you add a workaround for that, eg a prefs-option for some sort of pause switch? Switching to Edit is no solution as the currently drawn curve gets canceled by that.

I am aware of these limitations, but haven’t been able to find any satisfactory solution so far. The workaround I would suggest is:

  • draw the curve with Flexi draw and finish the drawing (space / enter / double click)
  • press E to switch to Flexi Edit and adjust the viewport
  • press E to switch back to Flexi Draw
  • snap to the end point of the curve drawn earlier (ALT + LMB) and continue drawing

Of course, this is not a very good work-around. But maybe you will have to work with this until a better solution is available.

1 Like

Thanks, yes currently that seems the fastest way, just one more thought on this. As default Ctrl is gridsnap and Alt is point snap. They don’t make much sense in combination. Wouldn’t that be a possible preference option to use that combination for view rotate instead?

1 Like

Yeah. Someone else was having issues with other addons with Maya style viewport controls. I use 3DS Max style in blender and seems to work better with most all addons.

I am using MMB for Panning, alt + MMB for rotate and ctrl+ alt + MMB for smooth zoom, or scroll wheel.
Although can be confusing when I have to go into Maya sometimes or Painter/Toolbag/etc.

I have a bunch of crown molding from years ago I can just append this profile use flexi bezier tool to draw where I want this molding to be apply bevel and all done.
The problem is that if I draw a custom profile with the flexi bezier tool and then apply bevel it gets flipped and I have to use the mirror tool in edit mode a few times to get the profile to be correct.
Is there a setting I am missing? Thank you for this great addon

Ector3 here is a helpful addon. Crown Molding Pack v2.0 It is available at the blendermarket.

1 Like

bkjernisted, thank you for your reply. I already own the crown molding addon and it is also not easy to add your own profiles. What I need is to be able to quickly design profiles on the fly. I also own the archipack pro version with a good molding feature.
What I ended up doing was using a regular bezier curve and edit it then use the flexi bezier tool to draw the paths

1 Like

If beziers aren’t required for what you’re doing Polysweeper might be another addon to look into if you haven’t yet.

1 Like

Thanks obsurveyor, yes I also own polysweeper and tried it. What I need to achieve is not impossible to do It would just be so much simpler if I draw the shape with flexi bezier draw the path with flexi bezier and set bevel and done.
If I take a curve profile made by extruding a curve and I make an exact copy of that profile but draw it with flexi bezier when I add this to bevel of another curve. I get two completely different results although the two profiles look identical.
Flexi bezier is amazing at creating accurate profiles. I no longer have to use a cad program and then import back to blender


I am unable to visualize the problem. Would it be possible for you to elaborate a little further, maybe using a small video?

1 Like

@Ector3 You can use ShareX to capture and record your desktop (free and open-source software): https://getsharex.com/

xan2622, thank you for letting me know about sharex its awesome. Here is a video of the prosses I used maybe I am missing something. Or just approaching this the wrong way


Just apply the rotation (Ctrl+A) of the curve you created with Flexi Tool.

1 Like

Have made the changes as per your suggestions. Also, enabled snap point indicator by default in Flexi Draw.


Khemadeva, thank you so much. Apply rotation worked like a charm. Two clicks and problem solved

1 Like