Flickering on Render - mostly solved

When the camera changes position then those frames through the change render with flickering. I’ve tried changing out every lamp and changing all lamps to and from raytracing types, still I get the flicker result.
It may be related to camera clipping, but I can’t find any setting which works.
I’m including the blend in case anyone has a solution. A deadline is approaching, so any help would be greatly appreciated.
Here’s a very short animation of the problem:

In an effort to keep my plea in view. . . :expressionless:

Pam, the first link is forbidden and the 6monkeys one says no such file. You can send it to me ([email protected])


Well, it wasn’t that the walls needed to be set smooth for shadow, but that one of them had the normal flipped out. Also, the flickering went away first, even when set smooth, when I depressed the ‘No V.Normal Flip’ in the Edit Panel. Who knew?
Thanks to all who may have looked into this, and especially to Fligh % for sending a message to me.
If anyone has other suggestions for any of the animation, I’m glad to receive them.
I’m taking out the web links to my blend, as it seems no one was able to download them.

I played with it but couldn’t do any better than your ‘no normals flip’ solution.


I didn’t have any trouble finding the blend file in your album (I think the link you posted was a little different):


I played with the file also.

It seemed strange at first, because if I dropped in another Camera at the same location as the camera you are using (Camera.001, I believe) it would render out fine, so at first I thought it was something to do with the camera. However, changing about every Camera setting had no effect.

After seeing your “No V. Normal Flip” solution, I got another idea.

It seems as though at some point in time, you hit “Set Smooth” for the Cube exterior wall as well as the work bench; although these objects are not smooth at all (all surfaces are at 90 degree angles to one another) .

You can confirm this by going in to Local view mode. You’ll see in Solid View mode a “grayish” tint to the surfaces. Select all the vertices and hit “Set Solid” for both the walls and the work bench.

What’s happening is that Blender is trying to treat the surfaces as smooth although they are quite angled, so with the slight Camera movement, it’s causing the normals to flip. (which is why enabling “No V. Normal Flipping” cures it).
For the swords, your solution is probably the best option.

Also, for Camera.001, you had duplicate identical track to Constraints. (though it didn’t seem to cause any bad effect).
Quite a few of the normals were pointing the wrong way, but correcting them had no effect because of the “Set Smooth” option being set.

The lighting looked a little dark here, but other than that everything looked quite nice.

Thanks for your explanations. I had a total misunderstanding of the effect of ‘set smooth’.