Flip fluids add-on question

Hey there !

I’m creating a scene where a flying saucer fills up a glass. It has four emitters linked to it and is rotating and slightly moving on top of the glass.

I would like the fluid to directly aim at an empty, so that’s what I did, I set an empty as a target. However, the fluid seems to be slightly influenced by it, but not as much as I’d like. Maybe it’s about my fluid settings too. The empty is the axis you can see on the picture (Z and X).

Could someone help me with this ? Thank you !!!


Do you mind telling me where you get the AddOn?
I went to graphicall and downloaded a FLIP build, but nothing shows up under the physics buttons?

Does FLIP require an Addon and a special build of Blender?

Yes, you have to buy it from the blender market : https://blendermarket.com/products/flipfluids

Hey! When using a target on an inflow, this will set the direction of the emitted fluid velocity towards the target object. But in many cases the resulting fluid jet will not hit the target exactly. This is because the force of gravity will accelerate the fluid downwards which will make the fluid move off-course from the target.

There are two things you can try to get the fluid to hit the location you want:

  • Increase inflow speed - a higher speed will shoot the fluid towards the target faster and the pull of gravity will be less noticeable
  • Move the target object higher - Aiming the fluid direction higher than the target location will help account for the direction change due to the pull of gravity

And an extra optimization tip: It looks like you are using a low viscosity value. The viscosity solver that we implement is quite accurate for thick buckling liquids, but also adds a lot of time to the fluid simulation and can be overkill for low viscosity fluids. There is an trick that can be used in this simulator (as well as other FLIP-based simulators) to bypass enabling the viscosity solver and ‘fake’ a low viscosity fluid without adding any extra time to the simulation.

Disable the viscosity solver and instead increase the PIC/FLIP ratio value in the Advanced Panel. This setting mixes two types of simulation: FLIP which is accurate and chaotic, and PIC which is not very accurate and is very stable. Increasing the PIC/FLIP Ratio will mix in more PIC into the simulation. A less accurate PIC simulation ends up dissipating motion in the fluid, which ends up looking naturally like a low viscosity fluid. Try comparing the default 0.05 value with 1.0 to get an idea for how this affects the fluid.

Hope this helps!

1 Like

Hey there ! Setting the target higher and playing with the inflow speed worked for me, took a lot of tries but it’s here !

Going to play with the optimisation settings too, since my computer isn’t a huge machine haha. :slight_smile:

Thanks again !