FLIP Fluids Addon: A liquid fluid simulation tool for Blender

add-ons
commercial

(vollstock) #444

Can anyone point me to some information of how I could render my water surface like this:

I want to only render the surface in a narrow band. Everything closer or further away from the camer should be cut away.

I was playing with the Fresnel-Node and it kind of works OK, but then also smaller splashes inside of my band will also cut camera-facing faces.

Thanks :slight_smile:


(Klutz) #445

I understand pure bug fixes should have alphabetical version numbers, but if the API doesn’t allow them, maybe it’s better to use a minor numberung scheme, such as 1.0.4.1 in this case?


(RLGUY) #446

I agree that this would be better. Next time we will be incrementing the number. Not changing the version number in the panel has led to a lot of messages of and reports of installation issues due to misunderstandings which we did not expect.

Our apologies for the confusion!


(adrencg) #447

I’m having more success when making the scene and domain a little bigger…and even better yet when increasing world scaling. My sims were just looking too fat and blobby. So tell me if this sounds right to you (or anyone else reading)…

for example:

Scene objects equal 20 meters. If I change the world scaling in FLIP to 40 meters and increase the speed from 1 to 2, then that would make the speed correct…right?


(lumpyoatmeal) #448

I don’t know about changing the speed when scaling the world; maybe rlguy can answer that. I try keep my domain objects about 2 meters max. My domain grid resolution starts at 160 for basic testing, then I add 80 until I get to 320 or 400 (e.g., 160, 240, 320, 400).


(RLGUY) #449

Yes, this logic is correct. Also, an alternative to doubling the speed is to double the gravity vector.

Feel free to attach a .blend file that you are having trouble with and we could check out the settings and offer suggestions. Describe what you are trying to achieve and what problems you are encountering.

The trouble with whitewater might be with the size of your domain. The default settings for whitewater work well with domain sizes around 8 meters and larger. Tip #4 in this scene troubleshooting topic might be relevant: Simulation not generating enough whitewater. For a domain size of 2 meters, I would try out values of Min Engergy Speed = 0.1 and Max Energy Speed = 2.0. This may get the whitewater particles to behave more realistically.


(lumpyoatmeal) #450

Ok, thanks. I’ll try that.


(adrencg) #451

So, on the scale issue…

If I want my fluids to look thinner (even the viscous ones) it would be a good practice to increase the world scale and adjust speed accordingly. Are there any other settings to use which could keep fluids from being fat and thick?


(Pavel_Blend) #452

Water Simulation:


But it seems to me that this water is not like real water.

(RLGUY) #453

For viscous fluids, the viscosity value depends on domain size. Using the same viscosity value, a small domain will be visually thicker than a large domain. Instead of scaling the domain you should be able to use a smaller viscosity value.

For non-viscous fluids, you shouldn’t need to scale the domain for the fluid to be ‘thinner’. I will need to see your .blend file to answer this questions. It sounds like there is something going wrong with the settings/simulator if you need to scale your domain and speed up time to get your fluids to behave better when using reasonable world sizes (greater than 1 meter).

Cool test, thanks for sharing! I think having a surface tension parameter within the solver would greatly improve smaller-scale water simulations like this. It’s something we’d like to add in the future. I can’t quite tell from the video, but if your subdivision level is not already set to 1, I think that would improve the look/detail of the droplets. Adding in motion blur (such as in a post-production effect or using the surface motion blur feature) could improve the flow the animation since the liquid is moving quite fast.


(lumpyoatmeal) #454

If you haven’t yet, you could also try asking on blender.stackexchange.com


(rafal_w) #455

Hey!
I have one question:
Is there a way to render the particles only (from the debbug system) without the mesh? Even the OpenGL render would be fine.


(Bernardo) #456

hi guys. I just updated to the new 1.04 version and I get an error every time I try to bake, even a new vanilla scene with just a cube domain and a sphere fluid object.

the error says: “FluidSimulationFrameStats_t” object has no attribute ‘surfaceblur’

any idea how to fix this?

Thanks!


(RLGUY) #457

Hey, sorry to say that I have not found a way to get the Blender OpenGL render to capture the particles. It seems that they are ignored when exporting images.

This type of error can happen if the old version was not completely uninstalled before installing the new version. The error looks to be caused by a mismatch between the fluid engine version and the addon version.

This error can also happen if Blender is not restarted between uninstalling and installing the new version since Blender will still have the old version scripts loaded. If that is the case, then a simple Blender restart should fix the error.

I would try to uninstall the addon, and then install the new version:

  1. Restart Blender
  2. Uninstall FLIP FLuids
  3. Restart Blender
  4. Install updated version

You may also manually uninstall the previous version by deleting the flip_fluids_addon folder in your Blender addons directory. For example, my flip_fluids_addon folder is located here:

C:\Users\Ryan\AppData\Roaming\Blender Foundation\Blender\2.79\scripts\addons\flip_fluids_addon

Hope this work for you! Let me know if you are still having problems.


(Bernardo) #458

thanks I’ll check today once I get back home! :slight_smile:


(Bernardo) #459

all working now, thanks :slight_smile:


(lumpyoatmeal) #460

I was having a problem with the fluid mesh penetrating an obstacle. I changed the Grid Resolution from 320 to 400, changed the Frame Substeps min from 4 to 8, max to 32, and changed the Safety Factor (CFL Number) from 5 to 2. That solved the problem.

I was wondering if increasing Frame Substeps has any benefit/helps when lowering the Safety Factor (CFL Number)?

Additionally, what problems does increasing Frame Substeps help with/solve?


(RLGUY) #461

Hey lumpyoatmeal,

This is a good question! I’ll start by explaining a bit on why substeps are needed and how they affect the simulation.

The simulator automatically figures out how many substeps to calculate during a frame. The number of substeps required is based on the velocity of the fluid. The faster the fluid particles, the more substeps the simulator will take. The simulator calculates the fluid physics equations on a grid and if fluid particles are moving fast, they will be travelling over multiple grid cells during a frame. The grid cells that the particles travel over are ‘skipped’ in calculations and this is what leads to decreased accuracy. The skipped grid cells could have important data that would have altered the trajectory of the particle, such as velocity data telling the particle to move away from an obstacle instead of passing through it. Taking more substeps leads to particles skipping less grid cells and also leads to more consistent physics.

In general, more substeps during a frame increases simulation accuracy. The Min Substeps and Max Substeps parameters are guidelines for the simulator on the range of substeps it should take during a frame.

  • The Min Substeps parameter is like a minimum threshold of accuracy that will force the simulator to take at least this many substeps during a frame.
  • The Max Substeps parameter sets the limit for how many substeps the simulator is allowed to take during a frame. If some fluid particles are moving fast enough so that the required number of substeps exceeds this parameter, the simulator will remove these particles from the simulation. The reason for having this parameter is to prevent simulation ‘blow ups’ in extreme cases. There is a chance that a particle may become unstable and take on an extremely high velocity. This could cause the simulator to require a very large number of substeps during a frame, blowing up the baking time. There is also a chance this particle could affect the data of other particles leading to a chain reaction. Having a limit for the number of substeps will eliminate this unstable particle before it can cause any trouble.

The CFL Number (which is short for Courant–Friedrichs–Lewy condition number and is a common parameter in simulation) is a constraint on how the simulator figures out how many substeps to take during a frame. This number is the maximum number of grid cells a particle can travel in a single substep. So if the CFL is set to two, the simulator will perform enough substeps so that the fastest moving particle travels no more than two grid cells during a single substep.

Short answers to the questions:

When decreasing the CFL Number, the simulator will automatically figure out how many substeps to take to maintain this level of accuracy. Unless the Min Substeps is greater than the number of substeps that the simulator requires due to the CFL Number, this setting will have no effect on the simulation. If you set Min Substeps to 1, the simulator will take the minimum number of substeps required to satisfy the CFL constraint.

Increasing Min Substeps will in general increase simulation accuracy. Tip: Increasing this value can help with high viscosity simulations. More substeps means a shorter time interval per substeps and this leads to putting less stress on the viscosity solver, preventing it from failing in high resolution or high viscosity simulations.

- Ryan


(lumpyoatmeal) #462

Excellent; thanks!


(RLGUY) #463

I just wanted to share Lucas Veber’s awesome new simulation. You may have seen his work before in this beach waves simulation. In this effect, Lucas combines the Blender ocean modifier with a FLIP Fluids simulation.

Check out the full animation and breakdown + resources on YouTube: https://www.youtube.com/watch?v=4ePy4AGf6cY


Blender Market Summer Sale

An early warning:

As always, we like to give advance notice of upcoming sales and promotions. We recently found out that the Blender Market will be hosting an end of Summer sale beginning September 18th! That means that we will be joining in for a FLIP Fluids Summer Sale: Part 2!

This will give those who missed our last sale an opportunity to get the addon at 25% off! Already have a copy of the FLIP Fluids addon? The Blender Market Summer Sale will be jam packed with a plethora of other fantastic addons and assets, so this is your chance to get in on this amazing value!

- The FLIP Fluids Team

We post about sales/promotions in advance on our Facebook Page and Twitter, but I’ll also keep you up to date on Blender Artists.

Development Update

Some things we’re currently working on for the next version:

  • New feature: Sometimes your whitewater settings are perfect except that an obstacle object is generating not enough whitewater OR generating too much whitewater. We have added a setting to obstacle objects called ‘Whitewater Influence’. This setting will scale/multiply the amount of whitewater generated around this obstacle. Example: a value of 1.0 will generate the normal amount of whitewater, a higher value such as 2.0 will double the amount, and a lesser value such 0.5 will halve the amount. This feature will pair well with the upcoming Decoupled Baking feature which will allow you to re-simulate whitewater to fine tune your settings without re-running the entire fluid simulation.
  • Simplified Whitewater Settings Panel: The whitewater settings panel contains many settings to customize the behaviour of the whitewater particles, but this large number of settings can be overwhelming and difficult for a beginner to figure out which settings are most important. We will be changing the UI for this panel to include two different whitewater panel view modes: Basic View and Advanced View. The Basic View will only display the most important whitewater settings and hide parameters that are more advanced or less likely to be used. The Advanced View will display all parameters and will be the same as the panel in the current version (1.0.4a). Here is a mockup of the new Basic View compared to the Advanced View (outlined settings are parameters considered to be advanced):

  • Cache Structure Overhaul: To get ready for implementing the Decoupled Baking feature, we are overhauling the way the cache is stored and how simulation settings/meshes are exported before the simulation begins. Here are some improvements that will be a side-effect of restructuring the cache:
    • An annoying part of exporting simulation settings/meshes is that whenever you update a setting, you must also re-export the object meshes. This can take a long time if you have high-detail meshes that are animated. We will be updating the way we export simulation settings/meshes so that you will have the option to skip re-exporting meshes.
    • We will be improving the speed at which settings/meshes are exported.
    • We will be improving the speed at which the simulator takes to initialize. This is the time between when the simulator starts up and when the first frame begins computing. This can take a while if there are high-detailed animated meshes.

The next version with the Decoupled Baking feature will be quite a large update for the addon. We may consider uploading experimental ‘Weekly Builds’ of the addon to keep you updated with the latest features and fixes.

- Ryan