Flip Fluids Scene will not render

So, I’ve rendered a simulation which took 5 days. Now, I have a great looking simulation and can see it
via an openGL render or, simply by looking at the rendered view.

blender simply will not render the scene. I can’t use the GPU for rendering (for some reason this crashes blender, even if I set the display to ‘full screen’. It just locks up and says I have nearly infanite time before it can render the next shot.

I tried turning off causicts, lowering the sampling (this is only 50 samples). lowering the light bounces.

Here is the blener file if you have time to look at it - https://www.dropbox.com/s/nslsrg2ys2y1uis/Shot_4.blend?dl=0

  • Blender Version: 2.79
  • FLIP Fluids Version: For this blender release
  • Operating System: window 10
  • CPU: Intel Xeon e5-1650 v3 3.5ghz
  • GFX: NVIDIA GeForce GTX 1080 Ti
  • RAM: 32gig

Hey, I just had a chance to check out the .blend file. I am not able to run the full simulation at the moment, so I am just basing this off of the current loaded frame in the file.

I suspect that you are running out of GPU memory. The screenshot shows that the render before crashing is using 8.5 GB and it looks like your GPU has a capacity of 11 GB.

I noticed that your foam particle scale is quite large:

foam_scale

For reference, this is how large the particle would be when rendering:

Rendering 2+ million of these objects as foam would explain the long expected render time. Tip: you can visualize how large the particles would be in the viewport (or viewport render) by unchecking the ‘Render Only’ checkbox. This will load the actual render geometry in the viewport, but I will warn that this could make the viewport quite slow and unresponsive.

I also noticed that there is quite a lot of whitewater particles being rendered. The bubble particles account for most of the whitewater particles at around 10 million. In my experience, Blender requires about 1 GB of GPU memory for every 1 million duplivert instances.

I would suggest reducing the amount of bubble particles rendered. You do not need to re-bake the simulation for this, you can set the percentage of particles rendered in the display panel:

display_percent

Hope this helps!

Just curious in general about this addon’s output. Can the output be exported as alembic cache?

Yep, but there is a workaround that you will need to use for Blender to export the meshes as an animation: https://github.com/rlguy/Blender-FLIP-Fluids/wiki/Scene-Troubleshooting#export-to-alembic-cache-is-not-exporting-animated-meshes

Alembic export is not officially supported in the FLIP Fluids addon. The reason for this is that the Blender Alembic exporter can be buggy and unstable with the large meshes produced by the fluid simulator. The Alembic exporter also does not offer much in terms of customizability, so how the cache is imported into other software may be unpredictable.

However, there is a workaround that may help you export the fluid meshes to an Alembic cache. In order for Blender to recognize the fluid object meshes for export ( fluid_surface , whitewater_foam , whitewater_bubble , whitewater_spray ), a modifier must be added to the objects. A modifier which does nothing such as a smooth operator with 0 repeats would be a good choice. The animated meshes can then be exported within Blender ( Blender > File > Export > Alembic (.abc) ).

Alembic export seems to be more stable for me in the 2.79 nightly builds. I recall there being some Blender Alembic bug fixes.

1 Like

Thanks, this is great to know since Alembic is my goto.

Wow, thank you so much for this response! Everything seems to be working so much better now. The only thing I can’t get to work is the scale preview of the foam. For some reason, that will only update when I render a frame, not in the viewport. UPDATE I forgot I had to change the frame. Thanks!!!